3 Replies Latest reply on Jul 16, 2008 4:32 AM by Hono Hsu

    JBOSS run Error

    Hono Hsu Newbie

      hi
      I runned $JBOSS_HOME/bin/run.sh to start JBOSS

      An error occured as follow:
      java.net.UnknownHostException: Server:Server
      at java.net.InetAddress.getLocalHost(InetAddress.java:1191)
      at net.sf.ehcache.Cache.(Cache.java:95)
      at net.sf.ehcache.config.ConfigurationHelper.createCache(ConfigurationHelper.java:308)
      at net.sf.ehcache.config.ConfigurationHelper.createDefaultCache(ConfigurationHelper.java:241)
      at net.sf.ehcache.CacheManager.configure(CacheManager.java:276)
      at net.sf.ehcache.CacheManager.init(CacheManager.java:208)
      at net.sf.ehcache.CacheManager.(CacheManager.java:195)
      at net.sf.ehcache.CacheManager.create(CacheManager.java:364)
      at net.sf.ehcache.CacheManager.getInstance(CacheManager.java:385)


      Anyone help me PLS?

        • 1. Re: JBOSS run Error
          Peter Johnson Master

          Please post the contents of your /etc/hosts file.

          Also, which Linux distro, and version, are you using?

          (You could also search the forums for the exception - I know this problem has been answered many times before.)

          • 2. Re: JBOSS run Error
            Hono Hsu Newbie

            Thanks Peter.

            My linux version is:
            Linux version 2.6.17.14

            And the contents of /etc/hosts is:

            # Do not remove the following line, or various programs
            # that require network functionality will fail.
            168.2.4.28 vernon.wang
            127.0.0.1 localhost

            Now I wanna using my machine as 192.168.41.203

            SO, the error occured

            BTW, I am serching the forums now.


            • 3. Re: JBOSS run Error
              Hono Hsu Newbie

              I find the answer in the forums, and fix it.
              Fix it as follow:


              monk2005



              Joined: Wed Mar 22, 2006 07:58 AM
              Posts: monk2005
              Location:
              Posted: Thu May 24, 2007 14:29 PM Post subject: Re: hostname

              --------------------------------------------------------------------------------

              Finally solved!

              1)
              Make sure that your server OS host file does the accurate transilation
              eg.

              127.0.0.1 localhost
              <external IP address> <computer name> <computer name with fully qualified domain name>

              2) Make sure that your server jndi.properties file uses the following instead of localhost:1099

              java.naming.provider.url=jnp://<computer name with fully qualified domain name>:1099

              this should do it - have fun!


              Back to top


              monk2005



              Joined: Wed Mar 22, 2006 07:58 AM
              Posts: monk2005
              Location:
              Posted: Fri May 25, 2007 09:15 AM Post subject: Re: hostname

              --------------------------------------------------------------------------------

              One more thing I forgot to mention.

              3) Start the server with -b option (bind address)

              eg.
              run -c <server name [if not given default]> -b <computer name with fully qualified domain name>

              Laterz

              Thanks peter again,
              and thanks monk2005.