11 Replies Latest reply on Aug 20, 2008 10:59 AM by claudia planner

    No answer after run command

    Marco Despontin Newbie

      Hello everybody,
      I'm new to Jboss and I have a really stupid problem, but I can't solve it... so, I really need your help to move forward...

      I set JAVA_HOME and JBOSS_HOME variables, installed Jboss-4.2.2.GA, on a Windows XP machine, but when I try to run the app server, the result is: completely no answer.

      My screen show only a blank row in this way:

      C:\jboss-4.2.2.GA\bin> run

      C:\jboss-4.2.2.GA\bin>

      any suggestions? what can I do?

        • 1. Re: No answer after run command
          jaikiran pai Master

          Post the output of:

          echo %JAVA_HOME%


          Also, you can remove the "@echo off" line from the run.bat and run that from the command prompt. That will show at what point the script is failing. If it has got anything to do with the findstr line, have a look at http://wiki.jboss.org/wiki/FindstrCommandNotFound


          • 2. Re: No answer after run command
            Marco Despontin Newbie

            Hi Jaikiran, thank you for your help.
            I removed the @echo off statemement and this allowed me to understand the problem: I didn't have the jvm.dll file in the bin/server folder in the java directory.
            So, I copied the bin/client content in a new bin/server folder and now everything seems to work.
            Thank you for your support,
            Marco

            • 3. Re: No answer after run command
              jaikiran pai Master

               

              "despontao" wrote:
              Hi Jaikiran, thank you for your help.
              I removed the @echo off statemement and this allowed me to understand the problem: I didn't have the jvm.dll file in the bin/server folder in the java directory.


              Looks like your JAVA_HOME value was actually pointing to a JRE instead of a JDK.


              • 4. Re: No answer after run command
                Marco Despontin Newbie

                yes, this was the situation, and I added the server folder in the jre.
                after your comment, I changed the jre with the jdk, but still the same problem. So, I corrected again in the same way: I created a new server folder, and copied all files from the client folder.

                Now I'm trying to compile one of the workbook example of EJB3 oreilly book, but something doesn't work properly.
                This is the output of ant statement:

                C:\workbook\ex04_1>ant clean.db
                Buildfile: build.xml
                
                clean.db:
                 [delete] Deleting directory c:\jboss-4.2.2.GA\server\default\data\hypersonic
                
                BUILD SUCCESSFUL
                Total time: 1 second
                C:\workbook\ex04_1>ant
                Buildfile: build.xml
                
                prepare:
                
                compile:
                 [javac] Compiling 4 source files to C:\workbook\ex04_1\build\classes
                 [javac] C:\workbook\ex04_1\src\main\com\titan\domain\Cabin.java:8: illegal c
                haracter: \64
                 [javac] @Entity
                 [javac] ^
                 [javac] C:\workbook\ex04_1\src\main\com\titan\domain\Cabin.java:9: illegal c
                haracter: \64
                 [javac] @Table(name="CABIN")
                 [javac] ^
                 [javac] C:\workbook\ex04_1\src\main\com\titan\domain\Cabin.java:23: illegal
                character: \64
                 [javac] @Id
                 [javac] ^
                 [javac] C:\workbook\ex04_1\src\main\com\titan\domain\Cabin.java:24: illegal
                character: \64
                 [javac] @Column(name="ID")
                 [javac] ^
                 [javac] C:\workbook\ex04_1\src\main\com\titan\domain\Cabin.java:34: illegal
                character: \64
                 [javac] @Column(name="NAME")
                 [javac] ^
                 [javac] C:\workbook\ex04_1\src\main\com\titan\domain\Cabin.java:44: illegal
                character: \64
                 [javac] @Column(name="DECK_LEVEL")
                 [javac] ^
                 [javac] C:\workbook\ex04_1\src\main\com\titan\domain\Cabin.java:54: illegal
                character: \64
                 [javac] @Column(name="SHIP_ID")
                 [javac] ^
                 [javac] C:\workbook\ex04_1\src\main\com\titan\domain\Cabin.java:64: illegal
                character: \64
                 [javac] @Column(name="BED_COUNT")
                 [javac] ^
                 [javac] C:\workbook\ex04_1\src\main\com\titan\domain\Cabin.java:72: <identif
                ier> expected
                 [javac] }
                 [javac] ^
                 [javac] C:\workbook\ex04_1\src\main\com\titan\travelagent\TravelAgentBean.ja
                va:9: illegal character: \64
                 [javac] @Stateless
                 [javac] ^
                 [javac] C:\workbook\ex04_1\src\main\com\titan\travelagent\TravelAgentBean.ja
                va:12: illegal character: \64
                 [javac] @PersistenceContext(unitName="titan") private EntityManager mana
                ger;
                 [javac] ^
                 [javac] C:\workbook\ex04_1\src\main\com\titan\travelagent\TravelAgentBean.ja
                va:12: <identifier> expected
                 [javac] @PersistenceContext(unitName="titan") private EntityManager mana
                ger;
                 [javac]
                 ^
                 [javac] C:\workbook\ex04_1\src\main\com\titan\travelagent\TravelAgentRemote.
                java:7: illegal character: \64
                 [javac] @Remote
                 [javac] ^
                 [javac] C:\workbook\ex04_1\src\main\com\titan\clients\Client.java:6: cannot
                access javax.naming.InitialContext
                 [javac] bad class file: C:\jdk1.5.0_15\lib\rt.jar(javax/naming/InitialContex
                t.class)
                 [javac] class file has wrong version 49.0, should be 47.0
                 [javac] Please remove or make sure it appears in the correct subdirectory of
                 the classpath.
                 [javac] import javax.naming.InitialContext;
                 [javac] ^
                 [javac] 14 errors
                
                BUILD FAILED
                C:\workbook\ex04_1\build.xml:54: Compile failed; see the compiler error output f
                or details.
                
                Total time: 1 second
                C:\workbook\ex04_1>


                Do you think there is still something wronk with my jdk?

                • 5. Re: No answer after run command
                  jaikiran pai Master

                  Going the compile time error messages, you are not pointing to the correct version of Java (using an older version of Java).

                  • 6. Re: No answer after run command
                    Marco Despontin Newbie

                    Finally I re-installed the jsk completely, and I deleted one space in the JAVA_HOME definition, and everything is fine. Thank you.

                    • 7. Re: No answer after run command
                      claudia planner Newbie

                      Hi,
                      I seem to have the same problem as described above.

                      When trying to start up the JBoss Server 4.2.3.GA on my Windows Vista 64 machine it stops at the following line:

                      C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin>"C:\Sun\SDK\jdk\jre\bin\bin\java" -server -version 2>&1 | findstr /I hotspot 1>nul

                      which seems to be a check for the -server flag of the the jvm.

                      I have no idea as to what the problem could be, since I just installed the most recent version of Java EE as well as the newest JDK. Also the findstr command is supported on my console.

                      I would be very thankful for any pointers or suggestions.

                      • 8. Re: No answer after run command
                        jaikiran pai Master

                        Can you remove the @echo off from the run.bat and then run it from the command prompt and post the entire output here? And what do you mean by

                        it stops at the following line


                        Does it hang? Or does the control return back to the command prompt? Also what does:

                        echo %JAVA_HOME%


                        output?

                        By the way, C:\Sun\SDK\jdk\jre\bin\bin\java looks suspicious. Are you sure its the correct path?

                        • 9. Re: No answer after run command
                          claudia planner Newbie

                           

                          Does it hang? Or does the control return back to the command prompt?

                          The control does return to back to the command prompt.

                          echo %JAVA_HOME% outputs:
                          C:\Sun\SDK\jdk\jre\bin

                          This is actually where I put my downloaded Java EE + SDK, bin being the directory where the client and server directories lie.

                          The whole output from trying to run it:



                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin>run

                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin>rem ------------------------------
                          -------------------------------------------

                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin>rem JBoss Bootstrap Script for Win32

                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin>rem ------------------------------
                          -------------------------------------------

                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin>rem $Id: run.bat 73584 2008-05-22
                          12:09:26Z dimitris@jboss.org $

                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin>set DIRNAME=.\

                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin>if "Windows_NT" == "Windows_NT" set DIRNAME=C:\Installs\jboss-4.2.3.GA\jboss4.2.3.GA\bin\

                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin>set PROGNAME=run.bat

                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin>if "Windows_NT" == "Windows_NT" set PROGNAME=run.bat

                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin>pushd C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin\..

                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA>set JBOSS_HOME=C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA

                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA>popd

                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin>REM Add bin/native to the PATH if present

                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin>if exist "C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin\native" set PATH=C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin\native;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;c:\Program Files (x86)\Microsoft SQL Server\90\Tools\binn\;C:\Program Files (x86)\SSH Communications Security\SSH Secure Shell;C:\Program Files (x86)\Common Files\Teleca Shared;C:\Program Files (x86)\QuickTime\QTSystem\;C:\Program Files (x86)\Java\jre1.6.0_07\bin;C:\Sun\SDK\bin;C:\Program Files (x86)\SSH Communications Security\SSH Secure Shell

                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin>if exist "C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin\native" set JAVA_OPTS= -Djava.library.path="C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;c:\Program Files (x86)\Microsoft SQL Server\90\Tools\binn\;C:\Program Files (x86)\SSH Communications Security\SSH Secu
                          re Shell;C:\Program Files (x86)\Common Files\Teleca Shared;C:\Program Files (x86)\QuickTime\QTSystem\;C:\Program Files (x86)\Java\jre1.6.0_07\bin;C:\Sun\SDK\bin;C:\Program Files (x86)\SSH Communications Security\SSH Secure Shell"

                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin>rem Find run.jar, or we can't continue

                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin>set RUNJAR=C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin\run.jar

                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin>if exist "C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin\run.jar" goto FOUND_RUN_JAR

                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin>if not "C:\Sun\SDK\jdk\jre\bin" == "" goto ADD_TOOLS

                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin>set JAVA=C:\Sun\SDK\jdk\jre\bin\bin\java

                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin>rem A full JDK with toos.jar is not required anymore since jboss web packages

                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin>rem the eclipse jdt compiler and javassist has its own internal compiler.

                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin>if not exist "C:\Sun\SDK\jdk\jre\bin\lib\tools.jar" goto SKIP_TOOLS

                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin>rem If JBOSS_CLASSPATH or JAVAC_JAR is empty, don't include it, as this will

                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin>rem result in including the local directory in the classpath, which makes

                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin>rem error tracking harder.

                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin>if not "" == "" set RUNJAR=;C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin\run.jar

                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin>if "" == "" set RUN_CLASSPATH=C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin\run.jar

                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin>if "C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin\run.jar" == "" set RUN_CLASSPATH=;C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin\run.jar

                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin>set JBOSS_CLASSPATH=C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin\run.jar

                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin>rem Setup JBoss specific properties

                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin>set JAVA_OPTS=-Dprogram.name=run.bat

                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin>rem Add -server to the JVM options, if supported

                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin>"C:\Sun\SDK\jdk\jre\bin\bin\java" -server -version 2>&1 | findstr /I hotspot 1>nul

                          C:\Installs\jboss-4.2.3.GA\jboss-4.2.3.GA\bin>





                          • 10. Re: No answer after run command
                            jaikiran pai Master

                             

                            echo %JAVA_HOME% outputs:
                            C:\Sun\SDK\jdk\jre\bin


                            This looks incorrect. The JAVA_HOME should be set to:

                            set JAVA_HOME=C:\Sun\SDK\jdk\jre


                            • 11. Re: No answer after run command
                              claudia planner Newbie

                              That was the problem, thank you very much!!!!