5 Replies Latest reply on Sep 4, 2008 10:25 AM by Peter Johnson

    JBOSS 4.2.3 GA supported J2EE Standards and Versions ?

    prasad y Newbie

      Hi,

      Any one can suggest me what version of Java and J2EE standards JBOSS4.2.3 GA supports..like

      JSP Version ?
      JAVA Version ?
      EJB Version ?
      JMS Version ?
      J2EE Version/Standard ?
      Servlets Version ?

      Where can i find exact document or brochere or report for this
      Thanks and Regards
      Prasad.Y

        • 1. Re: JBOSS 4.2.3 GA supported J2EE Standards and Versions ?
          Dimitris Andreadis Master

          The following page is about JBoss Enteprise Application Platform (EAP), which is based on the JBoss AS 4.2.x community project, so it's more or less accurate for AS 4.2.3.GA, too:

          http://www.jboss.com/products/platforms/application/standards

          • 2. Re: JBOSS 4.2.3 GA supported J2EE Standards and Versions ?
            prasad y Newbie

            Hi,

            Thanks for your response..

            The above said link provides the standards for th "JBoss Enterprise Application Platform 4.3 supports the following standards: ".

            I have the Following questions ?

            1) I belive and lerant from the docs that latest stable JBOSS Application server is JBOSS AS 4.2.3 GA . Correct me if i am wrong and specify me the correct version ?

            2) Is JBoss 4.2.3 GA comes under the JBoss Enterprise Application Platform 4.3 ?

            Thanks in advance for your help

            Thanks and Regards
            Prasad.Y

            • 3. Re: JBOSS 4.2.3 GA supported J2EE Standards and Versions ?
              Dimitris Andreadis Master

              All you need to know is

              JBossAS 4.2.3.GA is the latest community version (.org)

              JBoss EAP 4.2/4.3 is the latest supported version (.com)

              EAP originally included AS 4.2.1.GA. Through a consistent patch process the EAP version contains most bug fixes from the .org side of things, and more (e.g. customer requested/specific fixes that made it only on the supported EAP product).

              If you are happy being on your own with the support you can get from the community, you'll use the latest JBoss AS.

              If you want a product with commercial production support from JBoss/Redhat and specific SLAs, you need to use the latest EAP 4.3

              • 4. Re: JBOSS 4.2.3 GA supported J2EE Standards and Versions ?
                prasad y Newbie

                Hi Sir,

                Thanks so much for the updation...

                I would like to know are there any differences in related to commericial anc ommunity version releases of JBosses..

                Like

                1) What are the differneces in Application Server feature perspective like various version and standards of Java, performance , memory consuption , tools they support.

                2) What SLAs they give if we buy the commercial one. and what is the cost and how do they provide the support for commercial?

                3) what are Contact, support and service levels we can get both commerical and community versions ?

                4) How can evaluate , on what parameter basis of commercial and community version ?

                5) Are they any differnece for providing the documenation support for both commercial and community versions ?

                Thanks in advance for your help

                Thanks and Regards
                Prasad.Y

                • 5. Re: JBOSS 4.2.3 GA supported J2EE Standards and Versions ?
                  Peter Johnson Master

                  Most consultants change $$$ for the type of marketing research you are asking for...

                  You can always contact Red Hat support, they might provide these details.