2 Replies Latest reply on Sep 12, 2008 3:32 PM by Peter Johnson

    dataTable onRowClick not able to call java bean

    Katie Carpenter Newbie

      Hi,

      I'm upgrading from 3.1.3CR4 to 3.2.1. My current code:

       <a4j:region id="dataregion1">
       <rich:dataTable id="animaldatatable" binding="#{SearchBean.dynamicDataTable}" >
       <a4j:support ajaxSingle="true" event="onRowClick"
       action="#{SearchBean.rowClickAction}"
       reRender="indivanimalrichpanel, indivdatascroller, searcherror, recordtoolbar, editAllModal" />
       </rich:dataTable>
       </a4j:region>
      
      My call to the SearchBean is no longer happening. How do I need to modify my code to call this bean?
      
      Thank you!


        • 1. Re: dataTable onRowClick not able to call java bean
          Katie Carpenter Newbie

          Hello again,

          I'm fairly certain this is a syntax problem, but I have been unable to figure this out. I've tried changing my bean code to being setters/getters and that didn't work. I've also tried using a do method, but no luck there either. I'm able to call an alert window from the jsp, but not the bean class, which makes me think this must be syntax. I would really appreciate some help with this, as I'm new to RichFaces.

          • 2. Re: dataTable onRowClick not able to call java bean
            Peter Johnson Master

            Have you looked at the html source within your browser? I suspect that there would have to be be some JavaScript that make the asynch call back to the server. I would first attempt to make sure that JavaScript was firing (either by using proxy server or network monoitor to capture the traffic). I would use the code from 3.1.3 (which was working) to determine what the HTML should look like and to ascertain what traffic should appear and then use 3.2.1 to see what the new HTML looks like and to determine if the expected traffic is still appears.

            Only when I was certain that the event was being fired at the browser and the expected request was being sent to the server would I start messing with the bean, or looking at the app server code.

            By the way, what browser are you using? Does it work for a different browser?