1 Reply Latest reply on Nov 14, 2008 4:10 AM by Worrow W

    JBoss web service output

    Worrow W Newbie

      First off, hi to everyone.

      I am using JBoss 4.2.3 GA as an Application Server and NetBeans 5.0 as a client. I have no problem to get the service list from the server but when I tried to test one of the services(input data, then press submit), instead of result displays on the same window, I got some kind of
      'InvocationTargetException...malformed array type: arraytype'. However on the JBoss console, the server got the input and generate the result properly. NetBean 5.0 just can't get the result from JBoss to its output window. Any suggestion? Thanks in advance.

        • 1. Re: JBoss web service output
          Worrow W Newbie

          Finally found out what the problem is-->SOAP.

          The old setting is based on jbossws4ee but now JBoss 4.2.3 used jbossws. Without touching the war file, I tried to downgrade back to jbossws4ee but when I started JBoss, I got a message say "Could not create deployment:....Caused by: java.lang.ClassNotFoundException: No ClassLoaders found for: org.jboss.webservice.WebServiceClientDeployment
          " Anyone which jar file is this class located? Thanks in advance.