0 Replies Latest reply on Jan 22, 2009 1:51 PM by lindg.daffne

    Impossible to load Jboss 3.2.1 from Eclipse properly. "Start

    lindg.daffne Newbie


      I'm trying to run jboss server 3.2.1 (wonderLand) from eclipse but i ain't able to do it. I use JbossAS (several different versions) but all versions try to init jboss server with the argument "-b localhost" and this is a problem cause my version of jboss server (3.2.1) doesn't support this argument. (I tried with Jboss Server 4.x and all goes well cause this version of the server supports the "-b" modifier).

      This is not really the problem because if i remove the "-b localhost" argument from the configuration of JbossAs the Server starts well and all seems to be ok.

      The problem is that Eclipse seems to lost communication with the server because the message "Starting..." in the Sever View in Eclipse never ends (never change into "Started"). Although the server finally manages to start properly Eclipse never recognizes that.
      When I tried to start jboss server version 4.x Eclipse always recognized all the states of jboss and finally put "Started" or "Debugging" in Eclipse properly.

      Firstly i thought that it could be a problem with my version of jbossAs because the jboss server that i need to use is quite old (version 3.2.1) but i installed a previous version of Eclipse and jbossAs and nothing changed.

      Could anybody help me please?.