The latest stable JBossAS versions are:
1) In 4.x series - 4.2.3 GA
2) In 5.x series - 5.0.1 GA
Note that both these require a minimum JDK level 1.5
isnt it possible to make one of these versions compatible with Java 1.4..........
If yes plz let me know how to do that....
By the way, Java 1.5 is backward compatible. Which means that code written using JDK 1.4 is going to work with Java 1.5 too. Any specific reason, you want to stick to JDK 1.4?
Java 1.5 is backward compatible.
Are there lists or guides to see what you should watch out when using a Java 1.5 with an application written for Java 1.4.
Something like migrating best practices?
Thanks all for you responses!!!
Actually currently we are facing some problem with current version of JBoss4.0.2 and hence we plan to test our application with upgraded version.
Now Just for upgrading JBoss i dont think i will get permission to change entire JDK version itself as we may need to do lot of testing before we upgrade that.
So was interested if any workaround.
Also even if we think of moving to JDK1.5, plz let me know migrating best practices...!!!!!