3 Replies Latest reply on Apr 29, 2009 12:45 AM by Wolfgang Knauf

    Missing SecurityProxy.class in jboss5.0 application

    Heinz JRookie Newbie

      Hi all,
      I am trying to build a security related application for jboss5.0.0GA
      While buiding with ant I get

      [javac] F:\Entwicklung\JBoss_5.0\jw-0215-ejbsecurity\example\src\main\com\mkeym\customsec\ejb\TradingAccountSecurityProxy.java:16: canno
      t find symbol
      [javac] symbol : class SecurityProxy
      [javac] location: package org.jboss.security
      [javac] import org.jboss.security.SecurityProxy;


      So I guess it is the class SecurityProxy and a jar that keeps it that is missing. I searched for a jar and found
      http://www.java2s.com/Code/Jar/jboss-5.0.0.Beta2/Downloadjbosssxclientjar.htm
      where I found
      org.jboss.security.SecurityProxy.class
      So I downloaded the jbossx-client.jar, dated 05.04.2007. The error now is

      [javac] F:\Entwicklung\JBoss_5.0\jw-0215-ejbsecurity\example\src\main\com\mkeym\customsec\ejb\TradingAccountSecurityProxy.java:22: com.m
      keym.customsec.ejb.TradingAccountSecurityProxy is not abstract and does not override abstract method init(java.lang.Class,java.lang.Class,ja
      va.lang.Class,java.lang.Class,java.lang.Object) in org.jboss.security.SecurityProxy
      [javac] public class TradingAccountSecurityProxy implements org.jboss.security.SecurityProxy {
      [javac] ^
      [javac] Note: Some input files use or override a deprecated API.
      [javac] Note: Recompile with -Xlint:deprecation for details.
      [javac] Note: Some input files use unchecked or unsafe operations.
      [javac] Note: Recompile with -Xlint:unchecked for details.
      [javac] 1 error

      Is there a version problem? How can I find a suitable SecurityProxy.class ??
      Any advice ... ???
      Thanks in advance
      JRookie