3 Replies Latest reply on May 12, 2009 11:30 AM by Peter Johnson

    Running JBoss 5.1.0CR with Eclipse/WTP

    Wolfgang Knauf Master

      Hi to all,

      I found that JBoss 5.1.0CR1 will not run if using Eclipse/WTP (3.0). The error is:

      Failed to boot JBoss:
      org.jboss.xb.binding.JBossXBException: Failed to parse source: file:/C:/temp/jboss-5.1.0.CR1/server/default/conf/bootstrap/vfs.xml@13,37
       at org.jboss.xb.binding.parser.sax.SaxJBossXBParser.parse(SaxJBossXBParser.java:177)
       at org.jboss.xb.binding.UnmarshallerImpl.unmarshal(UnmarshallerImpl.java:147)
       at org.jboss.bootstrap.microcontainer.TempBasicXMLDeployer.deploy(TempBasicXMLDeployer.java:150)
       at org.jboss.bootstrap.microcontainer.ServerImpl.doStart(ServerImpl.java:138)
       at org.jboss.bootstrap.AbstractServerImpl.start(AbstractServerImpl.java:450)
       at org.jboss.Main.boot(Main.java:216)
       at org.jboss.Main$1.run(Main.java:546)
       at java.lang.Thread.run(Unknown Source)
      Caused by: org.jboss.xb.binding.JBossXBRuntimeException: {urn:jboss:bean-deployer:2.0}property cannot appear in this position. Expected content of {urn:jboss:bean-deployer:2.0}bean is sequence: {urn:jboss:bean-deployer:2.0}alias* {urn:jboss:bean-deployer:2.0}related-class* {urn:jboss:bean-deployer:2.0}annotation* {urn:jboss:bean-deployer:2.0}classloader? {urn:jboss:bean-deployer:2.0}constructor? {urn:jboss:bean-deployer:2.0}property* {urn:jboss:bean-deployer:2.0}create? {urn:jboss:bean-deployer:2.0}start? {urn:jboss:bean-deployer:2.0}stop? {urn:jboss:bean-deployer:2.0}destroy? {urn:jboss:bean-deployer:2.0}depends* {urn:jboss:bean-deployer:2.0}demand* {urn:jboss:bean-deployer:2.0}supply* {urn:jboss:bean-deployer:2.0}install* {urn:jboss:bean-deployer:2.0}uninstall* {urn:jboss:bean-deployer:2.0}incallback* {urn:jboss:bean-deployer:2.0}uncallback*
       at org.jboss.xb.binding.sunday.unmarshalling.SundayContentHandler.startElement(SundayContentHandler.java:449)
       at org.jboss.xb.binding.parser.sax.SaxJBossXBParser$DelegatingContentHandler.startElement(SaxJBossXBParser.java:401)
       at org.apache.xerces.parsers.AbstractSAXParser.startElement(Unknown Source)
       at org.apache.xerces.xinclude.XIncludeHandler.startElement(Unknown Source)
       ...


      Solution: in the "Servers" view, open the server, click the "Launch configuration" link, switch to the tab "Arguments" and add this VM argument:
      -Dxb.builder.useUnorderedSequence=true


      See https://jira.jboss.org/jira/browse/JBAS-6744 for an explanation.

      Here http://www.informatik.fh-wiesbaden.de/~knauf/public/ you will find an eclipse plugin, which brings this parameter (and integrates the WebBeans jars in WTP)

      Best regards

      Wolfgang