3 Replies Latest reply on Aug 19, 2009 11:37 AM by Peter Johnson

    JBoss Portal Crash after deploying portlet

    Bob Smith Newbie

      I am using jboss-portal-2.7.2 and have created an new Portal (i am very new to jboss!)
      Everything worked fine until i deployed the email-portlet. After i got it working in the portal i confiured it for an mail-server. the next thing that happened was that the portlet didnt work anymore. after i restarted the portal the portal itself didnt work anymore.
      after login it shows this error message

      exception
      
      javax.servlet.ServletException: java.lang.NullPointerException
       org.jboss.portal.server.servlet.PortalServlet.service(PortalServlet.java:278)
       javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
       org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
      

      as solution i tried the following:
      - undeploy the email-portlet
      - deleting folders under jboss-portal-2.7.2\server\default except conf, deploy and lib

      but the error message still appears. anyone an idea how i can solve such a problem?

        • 1. Re: JBoss Portal Crash after deploying portlet
          Peter Johnson Master

          The exception you posted looks like it appeared in your browser. There should be a corresponding exception in the console log, please post that.

          Portal keeps config info in a database. You might also have to wipe the database to get back to a clean system. In other words, removing the data, temp , log and work dirs is not enough (unless you are using the HSQLDB database, in which case it stores its data in the data directory).

          • 2. Re: JBoss Portal Crash after deploying portlet
            Bob Smith Newbie

            thx for reply.
            I indeed use HSQLDB, as i am just testing before real development. So i expected all the config to be reset after deleting the folders.
            Maybe this part of the console log is helpful.

            --- MBEANS THAT ARE THE ROOT CAUSE OF THE PROBLEM ---
            ObjectName: jboss.web.deployment:war=portal-identity.war,id=-1456428062
             State: FAILED
             Reason: org.jboss.deployment.DeploymentException: URL file:/C:/jboss-portal-2.
            7.2/server/default/deploy/jboss-portal.sar/portal-identity.sar/portal-identity.w
            ar/ deployment failed
            
            ObjectName: jboss.web.deployment:war=portal-admin.war,id=-2037919538
             State: FAILED
             Reason: org.jboss.deployment.DeploymentException: URL file:/C:/jboss-portal-2.
            7.2/server/default/deploy/jboss-portal.sar/portal-admin.sar/portal-admin.war/ de
            ployment failed
            
            ObjectName: jboss.web.deployment:war=emailPortlet-web-1.0.war,id=-601299710
             State: FAILED
             Reason: org.jboss.deployment.DeploymentException: URL file:/C:/jboss-portal-2.
            7.2/server/default/tmp/deploy/tmp35985emailPortlet-web-1.0-exp.war/ deployment f
            ailed
            
            ObjectName: jboss.web.deployment:war=portal-wsrp-admin.war,id=1416039848
             State: FAILED
             Reason: org.jboss.deployment.DeploymentException: URL file:/C:/jboss-portal-2.
            7.2/server/default/deploy/jboss-portal.sar/portal-wsrp.sar/portal-wsrp-admin.war
            / deployment failed


            • 3. Re: JBoss Portal Crash after deploying portlet
              Peter Johnson Master

              That is just the report the deployer prints at the end of the deployment, it does not tell why things went wrong. I really need to see the very first exception stack trace in the console log when your start the app server.

              Considering that various changes you have made, and that the deployment report indicates that some of the modules that ship with Portal did not deploy, you might want to reinstall the Portal and run it first to ensure there are no problems, and then try with your portlet again.