2 Replies Latest reply on Oct 21, 2009 9:20 AM by Tobias Hoppenthaler

    Migrate from Jboss 4.2.2GA to 5.1.0GA - HELP!

    Tobias Hoppenthaler Newbie

      Hi there,

      I have an application that worked perfectly fine in jboss 4.2.2 and I cannot get it to run in 5.1.0.

      What I did so far is:
      I removed all the jars from 4.2.2 that my app used an replaced them with the jars from 5.1.0. There were some minor changes like DatabaseServerLoginModule is in another package now, but I figured that out, so I got rid of all the red xes in my project (using Eclipse as the IDE).

      But when I deploy the jar file to the server, I get the following ERROR:

      2009-10-16 15:09:40,198 ERROR [org.jboss.system.server.profileservice.ProfileServiceBootstrap] (main) Failed to load profile: Summary of incomplete deployments (SEE PREVIOUS ERRORS FOR DETAILS):


      followed by a huge list of Missing dependencies - actually all my service beans are in state UNRESOLVED when they should be in DESCRIBED:

      DEPLOYMENTS MISSING DEPENDENCIES:
       Deployment "jboss.j2ee:jar=com.company.server.jar,name=AnonymServiceBean,service=EJB3" is missing the following dependencies:
       Dependency "<UNKNOWN jboss.j2ee:jar=com.company.server.jar,name=AnonymServiceBean,service=EJB3>" (should be in state "Described", but is actually in state "** UNRESOLVED Demands 'jndi:PartnerDAOImpl/local-com.company.core.dao.PartnerDAO' **")
       Dependency "<UNKNOWN jboss.j2ee:jar=com.company.server.jar,name=AnonymServiceBean,service=EJB3>" (should be in state "Described", but is actually in state "** UNRESOLVED Demands 'jndi:PersonDAOImpl/local-com.company.identity.dao.PersonDAO' **")
       Dependency "<UNKNOWN jboss.j2ee:jar=com. company.server.jar,name=AnonymServiceBean,service=EJB3>" (should be in state "Described", but is actually in state "** UNRESOLVED Demands 'jndi:ContactServiceBean/local-com. company.service.interfaces.ContactServiceLocal' **")
       Dependency "<UNKNOWN jboss.j2ee:jar=com. company.server.jar,name=AnonymServiceBean,service=EJB3>" (should be in state "Described", but is actually in state "** UNRESOLVED Demands 'jndi:CustomerServiceBean/local-com. company.sales.service.interfaces.CustomerServiceLocal' **")
       Deployment "jboss.j2ee:jar=com. company.server.jar,name=AnonymServiceBean,service=EJB3_endpoint" is missing the following dependencies:
       Dependency "jboss.j2ee:jar=com. company.server.jar,name=AnonymServiceBean,service=EJB3" (should be in state "Configured", but is actually in state "PreInstall")
       Deployment "jboss.j2ee:jar=com. company.server.jar,name=AreaSequenceNodeDAOImpl,service=EJB3" is missing the following dependencies:
       Dependency "<UNKNOWN jboss.j2ee:jar=com. company.server.jar,name=AreaSequenceNodeDAOImpl,service=EJB3>" (should be in state "Described", but is actually in state "** UNRESOLVED Demands 'persistence.unit:unitName=#company' **")
       Deployment "jboss.j2ee:jar=com. company.server.jar,name=AreaSequenceNodeDAOImpl,service=EJB3_endpoint" is missing the following dependencies:
       Dependency "jboss.j2ee:jar=com. company.server.jar,name=AreaSequenceNodeDAOImpl,service=EJB3" (should be in state "Configured", but is actually in state "PreInstall")
      ... to be continued ...


      This list goes on and on and on... and I have no clue, what I am doing wrong or where I could look for the error. Since I am pretty new to jboss, I would appreciate any help.

      Thanks a lot,

      Tobias