1 Reply Latest reply on Nov 2, 2009 7:32 AM by Nuno Teodoro

    Applet deployment problem

    Nuno Teodoro Newbie

      Ok, only now i noticed there is a beginner's corner, sorry about posting in another location in the forum. So, i'm going to repeat myself bu i have the following problem:

      I have an applet which i want to deploy with jboss. the problem is i only can load the .html file, the applet is not loaded, and the error i get is that the classes are not found.

      Everything works outside jboss but somehow it cannot find the class code.

      Here's what i've done: I have a .html file and a classes directory (which contains the .class files for the applet).
      I made a .war file with those 2 items.
      I placed that .war file under <jboss path>server/default/deploy

      i opened the file in the browser and i can see the html code but the applet is not loaded because it cannot find the classes. But why, if they are in the same directory(the .war file)?

      Thanks for your help.

        • 1. Re: Applet deployment problem
          Nuno Teodoro Newbie

          hm, seems this doesnt has a edit button. Ok, so now i've created the WEB-INF and META-INF folders and placed the web.xml inside web-inf. I also created a classes folder inside web-inf, where i copied the directories structure and classes.

          i have something like: web-inf/classes/noesis/zon/applets/*.class (all the classes)

          and in the web.xml i have a simple file like

          <?xml version="1.0" encoding="ISO-8859-1" ?>
          <web-app>
          <welcome-file-list>
          <welcome-file>GestaoDeInformacoesDiversas.html</welcome-file>
          </welcome-file-list>
          </web-app>


          inside the html file i have:

          <H3>Gestao de Informacoes Diversas</H3>


          <APPLET codebase="classes" code="noesis/zon/applets/GestaoDeInformacoesDiversas.class" width=650 height=350>






          I've created again a .war file with the web-ing, meta-inf and html file (meta-inf is empty because i dont know what to put there and if it is needed).

          i still can't load the applet, the html code appears fine but i get the same class not found for the applet..