4 Replies Latest reply on Nov 19, 2009 1:19 PM by Sergio Bazilio

    jBoss AS 5.1 Cluster - Problem 01

    Sergio Bazilio Newbie

      Hi Everybody.

      I Trying to set up a cluster of 2 jBoss as 5.1 nodes, but when i start the jboss app server , without any kind of application i am getting the following error:

      2009-11-18 17:50:00,376 ERROR [STDERR] (AOPListner) Exception in thread "AOPListner"
      2009-11-18 17:50:00,377 ERROR [STDERR] (AOPListner) java.util.ConcurrentModificationException
      2009-11-18 17:50:00,377 ERROR [STDERR] (AOPListner) at java.util.WeakHashMap$HashIterator.nextEntry(WeakHashMap.java:762)
      2009-11-18 17:50:00,377 ERROR [STDERR] (AOPListner) at java.util.WeakHashMap$KeyIterator.next(WeakHashMap.java:795)
      2009-11-18 17:50:00,377 ERROR [STDERR] (AOPListner) at org.jboss.aop.AspectManager.getAdvisors(AspectManager.java:537)
      2009-11-18 17:50:00,377 ERROR [STDERR] (AOPListner) at org.jboss.console.plugins.AOPLister$RefreshPoller.run(AOPLister.java:891)
      


      Here are my information:

      Initialization command:

      $JBOSS_HOME/bin/run.sh -c all -g Ozonion -b 10.246.71.191 -Djboss.messaging.ServerPeerID=1 -Djboss.service.binding.set=ports-default



      Here is my MSSQL-DS file:

      <datasources>
       <local-tx-datasource>
       <jndi-name>DefaultDS</jndi-name>
       <connection-url>
       jdbc:jtds:sqlserver://10.246.71.191:1433/jms;SendStringParametersAsUnicode=false;prepareSQL=2
       </connection-url>
       <driver-class>
       net.sourceforge.jtds.jdbc.Driver
       </driver-class>
       <user-name>user</user-name>
       <password>password</password>
       <max-pool-size>1024</max-pool-size>
       <min-pool-size>128</min-pool-size>
       <transaction-isolation>TRANSACTION_READ_COMMITTED</transaction-isolation>
       <blocking-timeout-millis>15000</blocking-timeout-millis>
       <idle-timeout-minutes>1</idle-timeout-minutes>
       <metadata>
       <type-mapping>MS SQLSERVER2005</type-mapping>
       </metadata>
       </local-tx-datasource>
      </datasources>
      



      Plus, i changed the $JBOSS_HOME/server/all/deploy/messages/hsqldb-persistence-service.xml for the example mssql-persistence-service.xml


      Something that i am missing?