2 Replies Latest reply on Oct 3, 2003 4:21 AM by lbalazs

    JMS problems on JBoss 4.0 DR2

    lbalazs Newbie

      Hi!

      I am developing an asynchronous J2EE app using the timer service and JMS, and since the standard timerservice is only available in JBoss 40 as far as I know, i have tried it.

      Well, i have massive problems to use the JMS facility: My beans get deployed, but i cant post any message from the outside to them with the same code which worked on 3.2.1. (Of course, recompiled with the new libraries, etc.)

      My questions are:
      - What has changed on the JMS, btw. what settings should i change to make it work?
      - Is there a possibility to upgrade 3.2.1 with the TimerService?
      - Will there be a new DR available in the near future (2 weeks) which fixes the problems (if there are any) ?

      Many thanks in advance,
      Balazs

        • 1. Re: JMS problems on JBoss 4.0 DR2
          lbalazs Newbie

          Details to the above JMS Error:

          If I post a msg from the outside to a JMS topic (with auto_ack), the client succeds without errors, and the server produces the following trace:

          00:33:34,698 WARN [SpyMessageConsumer] Error in getMessage()
          javax.jms.JMSException: Invalid transaction id.
          at org.jboss.mq.SpyXAResourceManager.ackMessage(SpyXAResourceManager.java:72)
          at org.jboss.mq.SpyMessageConsumer.preProcessMessage(SpyMessageConsumer.java:714)
          at org.jboss.mq.SpyMessageConsumer.getMessage(SpyMessageConsumer.java:677)
          at org.jboss.mq.SpyMessageConsumer.receive(SpyMessageConsumer.java:190)
          at org.jboss.resource.adapter.jms.MessageDelegate.run(MessageDelegate.java:60)
          at org.jboss.resource.work.WorkHolder.run(WorkHolder.java:143)
          at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Worker.run(PooledExecutor.java:727)
          at java.lang.Thread.run(Thread.java:534)

          But only on the first message, and it seems to ignore any msg afterwards.

          regards,
          balazs

          • 2. Re: JMS problems on JBoss 4.0 DR2
            lbalazs Newbie

            I have realized that this post is on the wrong palce here. I have reposted it in the user forums.

            sorry for any inconvinience.

            regards,
            balazs