8 Replies Latest reply on Jun 6, 2007 11:47 AM by Tim Fox

    Java 5 and JBM

    Tim Fox Master

      The next release of JBM (1.2.0.SP2) only works properly with JBAS 4.2.0 and later, and JBAS 4.2.0 or later requires JDK 5.

      Do you think we should stop supporting Java 1.4 with JBM?

      If we go Java 5 only, then we can start using the new language constructs, and benefit from the improved concurrency utils etc

      Do you think we should do this?

      Comments please.

        • 1. Re: Java 5 and JBM
          Weston M. Price Master

          Yes. I do.

          Backwards compatibility has it's place but when it becomes an obstacle in and of itself it's time to draw a line.

          • 2. Re: Java 5 and JBM
            Clebert Suconic Master

            I'm in vacation mode.. but I couldn't avoid looking at the dev forum/ answering this :-)

            IMO we should start using JDK 5. If someone come with a JDK 1.4 requirement later, we could use retroweaving.

            • 3. Re: Java 5 and JBM
              Tim Fox Master

              My inclination is to say move to JDK5, but I'd like to keep the thread open for a while longer to get some more opinions.

              • 4. Re: Java 5 and JBM
                Tim Fox Master

                On a related note, one consequence of the new Red Hat model, with the split between supported "platforms" and only developer supported other projects (such as ours) is that we don't have to support compatibility between our releases until we get into the platform (which we will fairly soon).

                Previously we used to spend a lot energy worrying about compatiblity, but at least this stone is lifted (for a while at least). This means we have no requirement to support compatibility with earlier clients, for example, which might be running JDK 1.4.

                • 5. Re: Java 5 and JBM
                  Clebert Suconic Master

                  Coming back to tech issues...

                  What about clients?

                  You require Java 5 on the server per JBAS 4.2.0, but what about clients?

                  Customers could have JDK 1.4 on clients and JDK 1.5 on server.

                  • 6. Re: Java 5 and JBM
                    Tim Fox Master

                     

                    "clebert.suconic@jboss.com" wrote:
                    Coming back to tech issues...

                    What about clients?

                    You require Java 5 on the server per JBAS 4.2.0, but what about clients?

                    Customers could have JDK 1.4 on clients and JDK 1.5 on server.


                    This is a good point.

                    My feeling on this is we should be JDK 5 only unless there is a specific requirement from running as part of the enterprise application platform that requires us to support JDK 1.4 clients.

                    • 7. Re: Java 5 and JBM
                      Markus Kobler Newbie

                      Because of JBM dependencies on JBoss AS 4.2 client libraries there does not seem to be a way for JBM to support 1.4 on the client side.

                      http://jira.jboss.com/jira/browse/JBPAPP-212?page=comments

                      In my honest opinion using solutions like JBossRetro, Retroweaver or Retrotranslator will simply add to the already large client-side dependencies, in addition to requiring an infeasible amount of testing to guaranty they don't have side effects.

                      As a side issue this should be made explicitly clear in the documentation so that users like that are constrained by 1.4 code are clear they are unable to use JBM.

                      • 8. Re: Java 5 and JBM
                        Tim Fox Master

                        The official JBoss / Red Hat line is that JBAS 4.2.0 is built using Java 5 since the enterprise app platform will only be supported when run using Java 5.

                        This is not something under my control.

                        However, in your case there may be a combination of jars we can use on the client side so you can run Java 1.4 on the client.

                        I'll get back to you soon on this.