Nothing big, but shouldn't we have some consistency in deployer object names (or ObjectNames in general) ?
I know we can get them from MainDeployer.listDeployers(), still I think it would make sense to put them all under "jboss.deployer" or include a "type=deployer" in their name, so they can be queried:
jboss.web:service=WebServer
jboss.jca:service=ConnectionFactoryDeployer
jboss.jca:service=RARDeployer
jboss.j2ee:service=ClientDeployer
jboss.ejb:service=EJBDeployer
jboss.j2ee:service=EARDeployer
jboss.deployer:service=BSHDeployer
jboss.bean:service=JBossBeanDeployer
jboss.ejb3:service=EJB3Deployer
jboss.aop:service=AspectDeployer
jboss.system:service=ServiceDeployer
jboss.system:service=JARDeployer
.war deployer no doubt has the most misleading name.
(a more interesting approach would be to use month names, April, July, etc. or even numbers Deployer1, Deployer2... :)
Yes, but the big problem is it breaks any existing depends. If we had an alias notion and the ability to use the alias as the depends target value I would have fewer qualms about changing the service names.