1 Reply Latest reply on Mar 12, 2004 3:40 PM by mycindyart

    problem in hot deploy in clustred environment(ASAP)

    sree anee Newbie


      "bajaj" wrote:
      "bajaj" wrote:
      hi guys,

      i have two jboss server running in clustered environment.

      both the system running with command as run -c all

      and farm-service.xml is like this

      <classpath codebase="lib" archives="jbossha.jar"/>
      <mbean code="org.jboss.ha.framework.server.FarmMemberService"
      name="jboss:service=FarmMember,partition=DefaultPartition" >
      <depends optional-attribute-name="Deployer">jboss.system:service=MainDeployer</depends>
      <attribute name="PartitionName">DefaultPartition</attribute>
      <attribute name="FarmDeployDirectory">./farm</attribute>
      <attribute name="ScannerName">jboss.deployment:type=DeploymentScanner,flavor=URL</attribute>

      when i deploy a ear file in server/all/farm directory this is deployed in the machine where i copied but in other system it is giving exception is like this

      [FarmMemberService] Could not find parent: farm for deployment: org.jboss.ha.framework.server.FarmMemberServiceMBean$FileContent@8c858a, data: Sun Aug 10 23:19:09 GMT+05:30 2003

        • 1. Re: problem in hot deploy in clustred environment(ASAP)
          mycindyart Newbie

          It is a problem with relative path. You need set up a directory same level as deploy and under deploy, both named 'farm'. Here is a sample xml:
          <?xml version="1.0" encoding="UTF-8"?>
          <!-- ==================================================================== -->
          <!-- Farming -->
          <!-- ==================================================================== -->

          TestPartition jboss.web:service=WebServer
          <depends optional-attribute-name="Deployer">jboss.system:service=MainDeployer

          You need to put this xml as farm-service.xml under deploy/deploy.last directory. And make true the two server has the same setting for farming.

          Hope the above helps.