I do not think there are any differences between the two.
According to the documentation and CVS source tree, it seems to be a renaming that occurs in JBossCache 1.2.
The timeToIdleSeconds in JBossCache < 1.2 became timeToLiveSeconds in 1.2.
I am not sure what you mean by turn "ON/OFF", but call to stop/start on the TreeCache will definitely "disable/enable" (actually more like undeploy/deploy) the cache.
Thomas is correct. timeToIdleSeconds is replaced by timeToLiveSeconds for clarity. But I am surprised that it causes any problem. Can you show me how can I reproduec this problem?
See the example unit tests in the distro on how to start/stop cache.
I got the exact same error when using the new name with an old JBossCache version (you have an old JBossCache package but you look at the latest documentation).
Using the correct value for the correct JBossCache version solved the problem for me.