1 Reply Latest reply on Jun 9, 2005 2:45 PM by Sean Gildea

    Surpassing configured max nodes for a region doesnt limit it

    Sean Gildea Newbie

      As a test, I set my xml config file to a max of 10 nodes. but I can insert past it with no error or problem.

      Here are my relevant xml settings. Maybe someone can tell me if Im doing something wrong.

      Thanks in advance,
      Sean Gildea

      <attribute name="EvictionPolicyClass">org.jboss.cache.eviction.LRUPolicy</attribute>
       <attribute name="EvictionPolicyConfig">
       <config>
       <attribute name="wakeUpIntervalSeconds">60</attribute>
      
       <region name="/_default_">
       <attribute name="maxNodes">10</attribute>
       <attribute name="timeToIdleSeconds">1000</attribute>
       </region>
       <region name="/atpcore/fares">
       <attribute name="maxNodes">10</attribute>
       <attribute name="timeToIdleSeconds">60</attribute>
       </region>
       </config>
      
       </attribute>
      
       <attribute name="FetchStateOnStartup">true</attribute>
       <attribute name="CacheLoaderClass">org.jboss.cache.loader.FileCacheLoader</attribute>
       <attribute name="CacheLoaderConfig">
       location=c:\\tmp\\oodb
       </attribute>
       <attribute name="CacheLoaderShared">false</attribute>
       <attribute name="CacheLoaderPreload">/atpcore/fares</attribute>
       <attribute name="CacheLoaderFetchTransientState">false</attribute>
       <attribute name="CacheLoaderFetchPersistentState">true</attribute>


        • 1. Re: Surpassing configured max nodes for a region doesnt limi
          Sean Gildea Newbie

          Ok,

          The problem is still occuring.

          My xml config settings are as follows

          <attribute name="EvictionPolicyConfig">
           <config>
           <attribute name="wakeUpIntervalSeconds">10</attribute>
          
           <region name="/_default_">
           <attribute name="maxNodes">20</attribute>
           <attribute name="timeToLiveSeconds">28800</attribute>
           </region>
           </config>


          If I run my 21 node insertion unit test with this configuration, it removes 6 leaving me with 15.

          If I run the same test with maxNodes set to 10, changing nothing else, it leaves me with 7 nodes after eviction.

          And if I run it with 5 maxNodes, it leaves 3.

          I was curious if anyone ran into this issue and figured out a resolution.