4 Replies Latest reply on Sep 19, 2005 2:37 AM by Bela Ban

    jboss-cache in weblogic 9.0

    Ragav Gomatam Novice

      Hi,

      I have the following problem using jboss-cache 1.2.3 with weblogic 9.0
      (a) I have configured jboss-cache as a start up class with weblogic 9.0.
      (b) I have commented out the TransactionManagerLookupClass attribute in the cache-config.xml as it was causing errors when trying to bind with
      weblogic jndi.

      (c) After that I am getting the following error in the console during start up of weblogic 9.0 :-
      (d) I am also using jgroups version 2.2.8 which is in the server classpath along with all the other jboss cache jars


      ================================================
      Starting JBoss cache using config file etc/jbosscache-config.xml
      <Sep 11, 2005 6:42:35 PM EDT> <BEA-000286> <Failed to invoke startup class "JBossCache-startup", ChannelException: failed loading class: java.lang.ClassNotFoundException: [Lorg.jgroups.Address;
      ChannelException: failed loading class: java.lang.ClassNotFoundException: [Lorg.jgroups.Address;
      at org.jgroups.conf.ClassConfigurator.init(ClassConfigurator.java:94)
      at org.jgroups.conf.ClassConfigurator.getInstance(ClassConfigurator.java:114)
      at org.jgroups.stack.ProtocolStack.(ProtocolStack.java:51)
      at org.jgroups.JChannel.(JChannel.java:205)
      at org.jgroups.JChannel.(JChannel.java:185)
      Truncated. see log file for complete stacktrace
      ===================================================

        • 1. Re: jboss-cache in weblogic 9.0
          Ragav Gomatam Novice

          Hi all ,

          After a lot of trial & frustation, I have found the solution, thought I might share with the forum...

          (1) Weblogic 9.0 and weblogic 8.1 sp4 appears to work only with jboss cache 1.1.1 and NOT the latest jboss cache 1.2.3....So I had to downgrade the version to get it working

          (2) I think, this is so because of the jgroups versions involved....Weblogic keeps throwing org.jgroups.Address not found exception inspite of jgroups.jar being in the server class path...

          (3) Also any attempts to bind to weblogic jndi using prefix "java:/jboss-cache"
          causes an Operation UnSupported Exception....Solution is to remove the
          "java:/" prefix and use a normal string instead to bind to weblogic context..

          Things are ok after that....

          • 2. Re: jboss-cache in weblogic 9.0
            Bela Ban Master


            (2) I think, this is so because of the jgroups versions involved....Weblogic keeps throwing org.jgroups.Address not found exception inspite of jgroups.jar being in the server class path...


            Can you show the exact error message ?

            I think this is due to JRockit, and I fixed this in JGroups 2.2.9. Can you try it out with 2.2.9 beta and let us know here ?

            • 3. Re: jboss-cache in weblogic 9.0
              Ragav Gomatam Novice

              Hi bela,

              Yes...Weblogic 9.0 Diablo works with JGroups 2.2.9 beta .... The error that I got was java.lang.ClassNotFoundException Lorg.jgroups.Address.. This was inspite of jgroups.jar in weblogic server class path....
              The version of jgroups I used was the one that was bundled with jboss-cache 1.2.3 which must be groups 2.2.8..

              I confirmed it as follows :- java -cp jgroups.jar org.jgroups.Version

              Whether this could be due to jrockit 1.5_03 , I don't know....Any way happy to be back in business....

              Finally is it ok to use jboss-cache-1.2.3 with jgroups 2.2.9 ? OR should I wait to upgrade to perhaps jboss-cache 1.2.4 ?

              • 4. Re: jboss-cache in weblogic 9.0
                Bela Ban Master

                Yes, JGroups 2.2.9 and 2.2.8 and 2.2.7 are compatible.
                This was caused by a problem in the JRockit/JGroups combo, which I resolved in JGroups 2.2.9.
                Glad it works now