1 Reply Latest reply on Sep 23, 2005 12:12 AM by Ben Wang

    Multicast not working

    Chad Bell Newbie

      After looking through the documentation and trying to create my own test applicaiton I am running into a problem. I can not get multicasting working on two different windows server. If I run the application on the same server in two different JVMs it works fine but if I run it on two different server it doesn't.

      I do admit I am new to JBossCache. I hope that it is somthing simple that I am not doing. I have tried the loopback to true and false with out any luck.

      Does anyone have any ideas?

      The following is my config xml:

      <server>
       <classpath codebase="./lib" archives="jboss-cache.jar, jgroups.jar"/>
       <mbean code="org.jboss.cache.TreeCache" name="jboss.cache:service=TreeCache">
       <depends>jboss:service=Naming</depends>
       <depends>jboss:service=TransactionManager</depends>
       <attribute name="TransactionManagerLookupClass">org.jboss.cache.JBossTransactionManagerLookup</attribute>
       <attribute name="IsolationLevel">REPEATABLE_READ</attribute>
       <attribute name="CacheMode">REPL_ASYNC</attribute>
       <attribute name="UseReplQueue">false</attribute>
       <attribute name="ReplQueueInterval">20000</attribute>
       <attribute name="ReplQueueMaxElements">5</attribute>
       <attribute name="ClusterName">TreeCache-Cluster</attribute>
       <attribute name="ClusterConfig">
       <config>
       <UDP mcast_addr="230.8.8.8" mcast_port="56677" ip_ttl="32" ip_mcast="true" mcast_send_buf_size="80000" mcast_recv_buf_size="150000" ucast_send_buf_size="80000" ucast_recv_buf_size="150000" loopback="true"/>
       <PING timeout="2000" num_initial_members="3" up_thread="false" down_thread="false"/>
       <MERGE2 min_interval="10000" max_interval="20000"/>
       <FD/>
       <VERIFY_SUSPECT timeout="1500" up_thread="false" down_thread="false"/>
       <pbcast.NAKACK gc_lag="50" retransmit_timeout="600,1200,2400,4800" max_xmit_size="8192" up_thread="false" down_thread="false"/>
       <UNICAST timeout="600,1200,2400" window_size="100" min_threshold="10" down_thread="false"/>
       <pbcast.STABLE desired_avg_gossip="20000" up_thread="false" down_thread="false"/>
       <FRAG frag_size="8192" down_thread="false" up_thread="false"/>
       <pbcast.GMS join_timeout="5000" join_retry_timeout="2000" shun="true" print_local_addr="true"/>
       <pbcast.STATE_TRANSFER up_thread="false" down_thread="false"/>
       </config>
       </attribute>
       <attribute name="InitialStateRetrievalTimeout">5000</attribute>
       <attribute name="SyncReplTimeout">10000</attribute>
       <attribute name="LockAcquisitionTimeout">15000</attribute>
       <attribute name="EvictionPolicyClass"/>
       <attribute name="FetchStateOnStartup">true</attribute>
       <attribute name="CacheLoaderClass">org.jboss.cache.loader.FileCacheLoader</attribute>
       <attribute name="CacheLoaderConfig">
       location=C:\\develop\\projects\\Cache\\node1
       </attribute>
       <attribute name="CacheLoaderShared">true</attribute>
       <attribute name="CacheLoaderPreload">/</attribute>
       <attribute name="CacheLoaderFetchTransientState">false</attribute>
       <attribute name="CacheLoaderFetchPersistentState">true</attribute>
       </mbean>
      </server>
      


      An my code for starting up the tree service is:

       TreeCachetree = new TreeCache();
       PropertyConfigurator config = new PropertyConfigurator();
       config.configure(tree, "replSync-service.xml");
       tree.createService();
       tree.startService();
      


      Thanks for the help.