0 Replies Latest reply on Oct 10, 2006 5:37 AM by Noga Tor

    Problem with inherited fields using the load-time instrument

    Noga Tor Newbie


      I am using PojoCache version 1.4.0 "Jalapeno".
      I run with java JDK 5.0.

      The Object I insert into the Cache is of class: "User".
      "User" is a sub-class of class"Person".
      Class Person has 2 fields "FirstName" and "LastName".

      For preparing the objects to instrumentation I use the Annotation method (possible with JDK 5.0).

      For the weaving stage, I have tried both the compile-time and load-time methods.

      The compile-time method worked fine and all fields (including inherited "FirstName" and "LastName" fields) were passed to other members in the cluster.

      However, when I tried using the load-time weaving, I encountered the following problem: All attributes from class "User" have been sent successfully to other members in the cluster but inherited fields ("FirstName" and "LastName") were not sent.

      To make sure, I checked this using ethereal. My checks confirmed this.
      I have seen updates sent to the cluster on all fields of "User" and no inherited "Person" fields.

      Does anyone know what can cause this problem? is this a known bug?

      I would appreciate any information on the subject.


      Btw, i tried all possible Annotations combination on classes "User" and "Person". no combination changed the situation.