1 Reply Latest reply on Nov 14, 2006 10:28 AM by aashishvora

    JBoss Cache in a cluster with more than 2 nodes

    aashishvora Newbie

      I have a JBoss Cache to replicate certain data between our cluster nodes. It works fine as long as we have 2 servers configured in the jbosscache-service.xml.
      When I add an entry related to the third member in the TCP protocol stack, when the third host is not running, Following sequence happens
      1) First one starts and acts as a coordinator
      2) Second one starts, creates a socket connection to the first one but does not participate in the same partition and becomes a coordinator by itself.
      3) They try to merge with each other , and both of them gets the following error after some time and both the nodes are not part of the same cluster and replication of my messages do not work.

      WARN [GMS] queue is suspended; request MERGE([host1:8800, host2:8800]) is discarded

      I guess both are trying to perform the merge and are blocking the response.
      Following is my configuration related to JGroups


      <TCP bind_addr="host1" start_port="8800" loopback="true"/>
      <TCPPING initial_hosts="host2[8800],host3[7800]" port_range="3" timeout="3500" num_initial_members="3" up_thread="true" down_thread="true"/>
      <MERGE2 min_interval="5000" max_interval="10000"/>
      <FD shun="true" timeout="2500" max_tries="5" up_thread="true" down_thread="true" />
      <VERIFY_SUSPECT timeout="1500" down_thread="false" up_thread="false" />
      <pbcast.NAKACK down_thread="true" up_thread="true" gc_lag="100" retransmit_timeout="3000"/>
      <pbcast.STABLE desired_avg_gossip="20000" down_thread="false" up_thread="false" />
      <pbcast.GMS join_timeout="5000" join_retry_timeout="2000" shun="false"
      print_local_addr="true" down_thread="true" up_thread="true"/>
      <pbcast.STATE_TRANSFER up_thread="true" down_thread="true"/>



      Is there a setting here that has to be modified to make it work in cluster of more than 2 members. Any help will be greatly appreciated.

      Thanks