4 Replies Latest reply on Dec 4, 2007 10:32 AM by Florian Marwede

    getRowData() not available on org.richfaces.component.html.H

    Julien Martin Expert

      Hello,

      I am totally puzzled. I changed richfaces from 3.0.1 to 3.1.0 and I get compilation errors as if the compiler could not find the methods inherited by org.richfaces.component.html.HtmlDataTable.

      It will not find the getRowData method. Any idea?

      Can anyone please help?

      Julien.

      Here is my POM:


      <?xml version="1.0" encoding="UTF-8"?>
      <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
       <modelVersion>4.0.0</modelVersion>
       <groupId>com.calyonfinancial</groupId>
       <artifactId>protide</artifactId>
       <packaging>war</packaging>
       <version>1.0-SNAPSHOT</version>
       <name>protide</name>
       <build>
       <finalName>protide</finalName>
       <plugins>
       <plugin>
       <artifactId>maven-compiler-plugin</artifactId>
       <configuration>
       <source>1.5</source>
       <target>1.5</target>
       </configuration>
       </plugin>
       </plugins>
       </build>
       <dependencies>
       <dependency>
       <groupId>org.hibernate</groupId>
       <artifactId>hibernate</artifactId>
       <version>3.2.1.ga</version>
       </dependency>
       <dependency>
       <groupId>org.hibernate</groupId>
       <artifactId>hibernate-annotations</artifactId>
       <version>3.2.1.ga</version>
       </dependency>
       <dependency>
       <groupId>org.hibernate</groupId>
       <artifactId>hibernate-entitymanager</artifactId>
       <version>3.2.1.ga</version>
       <exclusions>
       <exclusion>
       <artifactId>jboss-archive-browsing</artifactId>
       <groupId>jboss</groupId>
       </exclusion>
       </exclusions>
       </dependency>
       <dependency>
       <groupId>org.hibernate</groupId>
       <artifactId>hibernate-commons-annotations</artifactId>
       <version>3.3.0.ga</version>
       </dependency>
       <dependency>
       <groupId>org.hibernate</groupId>
       <artifactId>hibernate-validator</artifactId>
       <version>3.0.0.ga</version>
       </dependency>
       <dependency>
       <groupId>javax.persistence</groupId>
       <artifactId>persistence-api</artifactId>
       <version>1.0</version>
       </dependency>
       <dependency>
       <groupId>log4j</groupId>
       <artifactId>log4j</artifactId>
       <version>1.2.14</version>
       </dependency>
       <dependency>
       <groupId>com.sun.xml.bind</groupId>
       <artifactId>jaxb-impl</artifactId>
       <version>2.0</version>
       </dependency>
       <dependency>
       <groupId>com.sun.xml.bind</groupId>
       <artifactId>jaxb-xjc</artifactId>
       <version>2.0</version>
       </dependency>
       <dependency>
       <groupId>javax.xml.bind</groupId>
       <artifactId>jaxb-api</artifactId>
       <version>2.0</version>
       </dependency>
       <!--
       <dependency>
       <groupId>jdbc</groupId>
       <artifactId>as400</artifactId>
       <version>5.1.0.1</version>
       </dependency>
       -->
       <dependency>
       <groupId>javax.xml.bind</groupId>
       <artifactId>jsr173_api</artifactId>
       <version>1.0</version>
       </dependency>
       <dependency>
       <groupId>org.apache.myfaces.core</groupId>
       <artifactId>myfaces-api</artifactId>
       <version>1.1.5</version>
       </dependency>
       <dependency>
       <groupId>org.apache.myfaces.core</groupId>
       <artifactId>myfaces-impl</artifactId>
       <version>1.1.5</version>
       </dependency>
       <dependency>
       <groupId>javax.servlet</groupId>
       <artifactId>servlet-api</artifactId>
       <version>2.4</version>
       <scope>provided</scope>
       </dependency>
       <dependency>
       <groupId>javax.servlet</groupId>
       <artifactId>jsp-api</artifactId>
       <version>2.0</version>
       <scope>provided</scope>
       </dependency>
      <!--
       <dependency>
       <groupId>ajax4jsf</groupId>
       <artifactId>ajax4jsf</artifactId>
       <version>1.1.1</version>
       <exclusions>
       <exclusion>
       <groupId>javax.faces</groupId>
       <artifactId>jsf-api</artifactId>
       </exclusion>
       <exclusion>
       <groupId>javax.faces</groupId>
       <artifactId>jsf-impl</artifactId>
       </exclusion>
       </exclusions>
       </dependency>
      
       <dependency>
       <groupId>org.richfaces</groupId>
       <artifactId>richfaces</artifactId>
       <version>3.0.1</version>
       <exclusions>
       <exclusion>
       <groupId>javax.faces</groupId>
       <artifactId>jsf-api</artifactId>
       </exclusion>
       <exclusion>
       <groupId>javax.faces</groupId>
       <artifactId>jsf-impl</artifactId>
       </exclusion>
       <exclusion>
       <groupId>org.ajax4jsf</groupId>
       <artifactId>ajax4jsf</artifactId>
       </exclusion>
       </exclusions>
       </dependency>
       -->
       <dependency>
       <groupId>org.apache.poi</groupId>
       <artifactId>poi</artifactId>
       <version>3.0.1-FINAL</version>
       </dependency>
       <dependency>
       <groupId>com.calyonfinancial</groupId>
       <artifactId>util2</artifactId>
       <version>1.0.5</version>
       <scope>compile</scope>
       </dependency>
       <dependency>
       <groupId>com.calyonfinancial</groupId>
       <artifactId>multirealm</artifactId>
       <version>0.0.8</version>
       </dependency>
       <dependency>
       <groupId>com.calyonfinancial</groupId>
       <artifactId>userrolescache</artifactId>
       <version>0.0.2</version>
       </dependency>
       <dependency>
       <groupId>opensymphony</groupId>
       <artifactId>oscache</artifactId>
       <version>2.1</version>
       </dependency>
       <!-- -->
       <dependency>
       <groupId>org.richfaces.ui</groupId>
       <artifactId>richfaces-ui</artifactId>
       <version>3.1.0</version>
       <exclusions>
       <exclusion>
       <groupId>javax.faces</groupId>
       <artifactId>jsf-api</artifactId>
       </exclusion>
       <exclusion>
       <groupId>javax.faces</groupId>
       <artifactId>jsf-impl</artifactId>
       </exclusion>
       </exclusions>
       </dependency>
       </dependencies>
       <properties>
       <netbeans.hint.deploy.server>Tomcat55</netbeans.hint.deploy.server>
       </properties>
      </project><!--************************************************
      
      ************************************************-->
      
      



      Here is the errors I get:

      C:\dev\calyonfinancial\protide\src\main\java\com\calyonfinancial\protide\ContractManagedBean.java:[156,62] cannot access org.ajax4jsf.component.Sequen
      ceDataAdaptor
      file org\ajax4jsf\component\SequenceDataAdaptor.class not found
       Protide01p protide01pBean = (Protide01p) getProtide01p().getRowData();
      
      C:\dev\calyonfinancial\protide\src\main\java\com\calyonfinancial\protide\ContractManagedBean.java:[186,52] cannot find symbol
      symbol : method getRowData()
      location: class org.richfaces.component.html.HtmlDataTable
      
      C:\dev\calyonfinancial\protide\src\main\java\com\calyonfinancial\protide\ContractManagedBean.java:[210,52] cannot find symbol
      symbol : method getRowData()
      location: class org.richfaces.component.html.HtmlDataTable
      
      C:\dev\calyonfinancial\protide\src\main\java\com\calyonfinancial\protide\ContractManagedBean.java:[343,34] cannot find symbol
      symbol : method getRowIndex()
      location: class org.richfaces.component.html.HtmlDataTable
      
      C:\dev\calyonfinancial\protide\src\main\java\com\calyonfinancial\protide\ContractManagedBean.java:[344,52] cannot find symbol
      symbol : method getRowData()
      location: class org.richfaces.component.html.HtmlDataTable
      
      C:\dev\calyonfinancial\protide\src\main\java\com\calyonfinancial\protide\ContractManagedBean.java:[357,30] cannot access org.ajax4jsf.component.AjaxAc
      tionComponent
      file org\ajax4jsf\component\AjaxActionComponent.class not found
       HtmlAjaxSupport has = (HtmlAjaxSupport) e.getSource();
      
      C:\dev\calyonfinancial\protide\src\main\java\com\calyonfinancial\protide\ContractManagedBean.java:[358,47] cannot find symbol
      symbol : method getParent()
      location: class org.ajax4jsf.component.html.HtmlAjaxSupport
      
      C:\dev\calyonfinancial\protide\src\main\java\com\calyonfinancial\protide\ContractManagedBean.java:[377,59] inconvertible types
      found : java.lang.Object
      required: org.ajax4jsf.component.html.HtmlAjaxSupport
      
      C:\dev\calyonfinancial\protide\src\main\java\com\calyonfinancial\protide\ContractManagedBean.java:[378,56] cannot find symbol
      symbol : method getParent()
      location: class org.ajax4jsf.component.html.HtmlAjaxSupport
      


        • 1. Re: getRowData() not available on org.richfaces.component.ht
          Florian Marwede Expert

          Do you have an old Ajax4JSF lib in your library folder? Throw it out!

          • 2. Re: getRowData() not available on org.richfaces.component.ht
            Julien Martin Expert

            Thanks for your reply.
            I checked and rechecked: there are no old ajax4jsf libraries in the pom: here is the new pom:

            <?xml version="1.0" encoding="UTF-8"?>
            <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
             <modelVersion>4.0.0</modelVersion>
             <groupId>com.calyonfinancial</groupId>
             <artifactId>protide</artifactId>
             <packaging>war</packaging>
             <version>1.0-SNAPSHOT</version>
             <name>protide</name>
             <build>
             <finalName>protide</finalName>
             <plugins>
             <plugin>
             <artifactId>maven-compiler-plugin</artifactId>
             <configuration>
             <source>1.5</source>
             <target>1.5</target>
             </configuration>
             </plugin>
             </plugins>
             </build>
             <dependencies>
             <dependency>
             <groupId>org.hibernate</groupId>
             <artifactId>hibernate</artifactId>
             <version>3.2.1.ga</version>
             </dependency>
             <dependency>
             <groupId>org.hibernate</groupId>
             <artifactId>hibernate-annotations</artifactId>
             <version>3.2.1.ga</version>
             </dependency>
             <dependency>
             <groupId>org.hibernate</groupId>
             <artifactId>hibernate-entitymanager</artifactId>
             <version>3.2.1.ga</version>
             <exclusions>
             <exclusion>
             <artifactId>jboss-archive-browsing</artifactId>
             <groupId>jboss</groupId>
             </exclusion>
             </exclusions>
             </dependency>
             <dependency>
             <groupId>org.hibernate</groupId>
             <artifactId>hibernate-commons-annotations</artifactId>
             <version>3.3.0.ga</version>
             </dependency>
             <dependency>
             <groupId>org.hibernate</groupId>
             <artifactId>hibernate-validator</artifactId>
             <version>3.0.0.ga</version>
             </dependency>
             <dependency>
             <groupId>javax.persistence</groupId>
             <artifactId>persistence-api</artifactId>
             <version>1.0</version>
             </dependency>
             <dependency>
             <groupId>log4j</groupId>
             <artifactId>log4j</artifactId>
             <version>1.2.14</version>
             </dependency>
             <dependency>
             <groupId>com.sun.xml.bind</groupId>
             <artifactId>jaxb-impl</artifactId>
             <version>2.0</version>
             </dependency>
             <dependency>
             <groupId>com.sun.xml.bind</groupId>
             <artifactId>jaxb-xjc</artifactId>
             <version>2.0</version>
             </dependency>
             <dependency>
             <groupId>javax.xml.bind</groupId>
             <artifactId>jaxb-api</artifactId>
             <version>2.0</version>
             </dependency>
             <!--
             <dependency>
             <groupId>jdbc</groupId>
             <artifactId>as400</artifactId>
             <version>5.1.0.1</version>
             </dependency>
             -->
             <dependency>
             <groupId>javax.xml.bind</groupId>
             <artifactId>jsr173_api</artifactId>
             <version>1.0</version>
             </dependency>
             <dependency>
             <groupId>org.apache.myfaces.core</groupId>
             <artifactId>myfaces-api</artifactId>
             <version>1.1.5</version>
             </dependency>
             <dependency>
             <groupId>org.apache.myfaces.core</groupId>
             <artifactId>myfaces-impl</artifactId>
             <version>1.1.5</version>
             </dependency>
             <dependency>
             <groupId>javax.servlet</groupId>
             <artifactId>servlet-api</artifactId>
             <version>2.4</version>
             <scope>provided</scope>
             </dependency>
             <dependency>
             <groupId>javax.servlet</groupId>
             <artifactId>jsp-api</artifactId>
             <version>2.0</version>
             <scope>provided</scope>
             </dependency>
             <dependency>
             <groupId>org.apache.poi</groupId>
             <artifactId>poi</artifactId>
             <version>3.0.1-FINAL</version>
             </dependency>
             <dependency>
             <groupId>com.calyonfinancial</groupId>
             <artifactId>util2</artifactId>
             <version>1.0.5</version>
             <scope>compile</scope>
             </dependency>
             <dependency>
             <groupId>com.calyonfinancial</groupId>
             <artifactId>multirealm</artifactId>
             <version>0.0.8</version>
             </dependency>
             <dependency>
             <groupId>com.calyonfinancial</groupId>
             <artifactId>userrolescache</artifactId>
             <version>0.0.2</version>
             </dependency>
             <dependency>
             <groupId>opensymphony</groupId>
             <artifactId>oscache</artifactId>
             <version>2.1</version>
             </dependency>
             <dependency>
             <groupId>org.richfaces.ui</groupId>
             <artifactId>richfaces-ui</artifactId>
             <version>3.1.2.GA</version>
             <exclusions>
             <exclusion>
             <groupId>javax.faces</groupId>
             <artifactId>jsf-api</artifactId>
             </exclusion>
             <exclusion>
             <groupId>javax.faces</groupId>
             <artifactId>jsf-impl</artifactId>
             </exclusion>
             </exclusions>
             </dependency>
             </dependencies>
             <properties>
             <netbeans.hint.deploy.server>Tomcat55</netbeans.hint.deploy.server>
             </properties>
            </project>
            


            • 3. Re: getRowData() not available on org.richfaces.component.ht
              Julien Martin Expert

              I had forgotten to include the other two richfaces jars...