2 Replies Latest reply on Oct 7, 2008 3:26 PM by J B

    IGMP and Multicast

    J B Novice

      Hi Guys,

      Devleopment machines finally arrived in and I set up the app on 2 boxes. Now the 2 nodes dont see each other for whatever reason. I ran the the jgroups tests here http://www.jgroups.org/javagroupsnew/docs/manual/html/ch02.html#ItDoesntWork and none worked so told the sys admin guy to have a look at the network setup.

      He then asks me what version of IGMP do i need, reading this http://osdir.com/ml/java.javagroups.devel/2003-07/msg00009.html suggests that i dont need it??? Or do I ?? Using the jgroups lib from the 2.2GA release so thats 2.6.2.

      If i dont need it then what is the next steps i should take to see why the nodes cant see each other?? I suppose start looking at wireshark!!


        • 1. Re: IGMP and Multicast
          Bela Ban Master

          It doesn't matter which version of IGMP you use, the stack and switches should support versions 2 and 3 (and they usually do).
          You probably have a different issue, e.g.:
          - firewalls dropping packets
          - TTL = 0
          - Incorrect interfaces (bind_addr) for sending and receiving mcasts
          - VLANs dropping mcasts
          - Incorrect mcast addrs ( - can be dropped by the switch !)

          I suggest wireshark to see whether you're getting any mcast packets flowing between the boxes

          • 2. Re: IGMP and Multicast
            J B Novice

            Ok Thanks for the information Bela.

            Will start looking at wireshark and see whats going.