0 Replies Latest reply on Apr 15, 2008 4:05 AM by Adrian Wilford

    Will JBoss 5 be fully standards compliant?

    Adrian Wilford Newbie

      Hi I have recently had issues with JBoss 4.2.2GA not being fully JPA compliant, specifically:
      -JBoss not implementing the EJB 3.0 spec correctly so that it makes it very difficult to use another JPA provider like Toplink instead of Hibernate (I know that in the JBoss docs, it says that Hibernate is the only JPA provider that is supported, but this is counter to the idea of standards compliance allowing flexibility)

      Toplink is after all the reference implementation, and If the reference implementation is not supported, then it means that there is something seriously wrong!

      So.. will JBoss 5 be fully standards compliant allowing for maximum flexibility?

      Thanks