4 Replies Latest reply on Aug 21, 2002 5:50 PM by Eric Van

    Interesting Data Source Issue (Web Service related)

    Eric Van Newbie

      First off here is my version infomation

      jboss-3.0.0_tomcat-4.0.3
      apache axis 1_0 (beta 3)
      tomcat-3.3.1 (seperate instance for testing remote client)
      all running on windows

      Ok, now the issue.
      i am trying to expose an ejb as a web service using the EJBProvider that comes with apache's axis server.
      I have tested my ejb locally, from embeded tomcat instance, and remotely, from a seperate tomcat instance, and it works great.

      Now if i do the following steps i can get the web service to work fine.
      1. hit a jsp which calls the ejb directly (through jndi, rmi), doesn't matter if the jsp is in the local tomcat or a remote one.
      2. hit a jsp (in remote tomcat) which calls the web service.

      Everything runs great this way.

      The problem starts when i try to hit the web service jsp first. if i do then i get the dreaded

      java.sql.SQLException: OracleDS not bound

      in jboss and from that point on i cannot even call my ejb directly without getting the same error. But i can however hit a jsp in the local tomcat which simply gets a connection from that data source and returns a row count on one of my tables.

      I suppose that the EJBProvider is looking up the ejb in such a way that the datasource becomes unreachable, but i can't figure out why. I have even tried modifying the axis EJBProvider to include the package prefix information (org.jboss.naming:org.jnp.interfaces) when it constructs the JNDIContext (which it did not do before), but that had no affect.

      if any one has tackled this thing before i would really appreciate the help

      thnx,
      Eric