1 Reply Latest reply on Aug 25, 2002 12:29 AM by David Jencks

    Oracle9i config problem with EJB20

    kedar Newbie

      Hi,
      Another newbie to JBoss - using JBoss30 with Tomcat 403. I have modified the login-config / oracle-service for db configs - A simple jsp allows me to obtain connections from the java:/OracleDS namespace.

      When I try to deploy a simple Entity Bean (2.0) - No local/no relations. I see in the log that it is "creating" a table by the name of the abstract-schema specified or stating that it already exists. I already have a table in Oracle (named differently). Though it shows a successful deployment and I am able to obtain a reference to the home object - I cannot perform any operations (findBy / create etc).

      The table name it says exists, is a different name altogether. The exception is

      This is the start of the jbosscmp-jdbc.xml
      <jbosscmp-jdbc>

      java:/OracleDS
      <datasource-mapping>Oracle9i</datasource-mapping>
      <create-table>false</create-table>
      <remove-table>false</remove-table>
      <pk-constraint>false</pk-constraint>
      <preferred-relation-mapping>foreign-key</preferred-relation-mapping>



      The exception is

      java.lang.reflect.UndeclaredThrowableException: java.rmi.ServerException: RemoteException occurred in server thread; nested exception
      is:
      java.rmi.ServerException: Could not instantiate bean; nested exception i
      s:
      java.lang.InstantiationException: ejb.DummyEntity; nested exception is:


      Any help / guidance is greatly appreciated

      thanks,
      a newb-wannabe jbossian developer