4 Replies Latest reply on Feb 9, 2003 9:21 PM by jason

    OracelDS not bound

    Tobias Newbie

      Hi,

      I am going crazy a little bit, so I hope, someone could help me.
      I am working with JBoss3.0 and Oracle DB 8.1.7.0.0.
      I have put the classes12.zip into default/lib and copied the oracle-service.xml into the deploy directory. (Before, of course, I have changed the entries in this file).
      Well, I have tried to get a DataSource from Client Code by looking up via JNDI java:/OracleDS. The same I made within a SessionBean in the same context.

      Everytime I receive the same Exception (java´x.NameNotFoundException: OracleDS not bound).
      by looking up the DataSource.
      The deployer has succesfully deployed my oracle-service.xml and gave me the correct jndi name.

      Is there anybody, who could pass me some working files, or is there anyone, who could describe the changes which have to be made within oracle-service.xml,login-config.conf and/or standardjbosscmp-jdbc.xml

      Thanks a lot

        • 1. Re: OracelDS not bound
          David Jencks Master

          I find your question a little unclear. You can't access anything in the java: context from outside the jboss vm.

          • 2. Re: OracelDS not bound
            Tobias Newbie

            Sorry, if I have fromulated my question a little bit unclear.

            Well,
            I have tried to receive Data Source via Pooling.
            I have set up the oracle-service.xml as it is usual.

            The JBoss container deployed the description file successfully.
            Furthermore, I have written an EJB (Session Bean) to receive a connection object of the pool via JNDI.

            The session bean was deployed with success as well, but when I try to gain a connection from the pool by testclinet via session bean, I receive an exception by the
            jndi: OracleDS not bound (NameNotFoundException).

            My question:
            Has anyone a possible reason what I have made wrong.
            Everything is deployed successfully, but trying to gain a connection object is not possible (or could perhaps anybody send me his/her oracle-service.xml to see, waht I could have made wrong?)
            Thanks a lot

            • 3. Re: OracelDS not bound
              David Jencks Master

              First, check to see if java:/OracleDS really is bound. There should be a log message indicating that it is bound, and you should be able to see it in jndiView.

              TO use jndiview, point your browser at localhost:8080/jmx-console, find the jndiview mbean, click on it, click on the list operation. For older jboss versions , use localhost:8082/

              If it is not bound, examine server.log carefully in the section in which the datasource is being deployed. There will almost certainly be some clues about what is wrong.

              If it is bound, check your spelling carefully;-)

              • 4. Re: OracelDS not bound
                jason Newbie

                i checked the jdniview, which contains "service=LocalTxDS,name=OracleDS ...",
                pointed in localhost:8080/jmx-console, with oracle-service.xml and login-config.xml
                both depolyed successfully ever in jboss3.0.0 in default/deploy/ default/conf respectively,
                but it still issues exception after executin' client in another folder like
                "09:29:49,921 ERROR [LogInterceptor] TransactionRolledbackException, causedBy:
                javax.naming.NameNotFoundException: OracleDS not bound ..."

                there's two problems in consideration i suppose which is the root causes.
                first is the datasource that can't be access outside container which i saw in thread
                - http://jboss.org/forums/thread.jsp?forum=144&thread=23952&message=3764151&q=oracle+jboss3.0.4#3764151.
                second is a exception i saw on screen as below A), which i do not what it is and how
                to solve it if it's wrong.
                for the first consideration, the reason i doubt is that i'd ever successfully access
                BMP from the client in another folder (that i suppose it ought to be in another vm
                because i launch the client via another 'java ...' command, but i 'm not sure because
                i may be totally wrong in concept). additionaly, for the second consideration that it
                seems doesn't bound the datasource, but how am i able to view message appeared in
                jndiview?

                i appreciate any suggestions,
                thank you very much.

                env the app runs on is jboss3.0.4-tomcat4.1.12, j2sdk1.4.1_01

                (files used here are which ever got to work when in jboss verion 3.0.0,
                so i suppose the content may not go far wrong)

                ===
                A)
                "09:28:39,109 ERROR [URLDeploymentScanner] MBeanException: Exception in MBean ope
                ration 'checkIncompleteDeployments()'
                Cause: Incomplete Deployment listing:
                Packages waiting for a deployer:

                Incompletely deployed packages:

                MBeans waiting for classes:

                MBeans waiting for other MBeans:
                [ObjectName: jboss.jca:service=LocalTxCM,name=OracleDS
                state: CONFIGURED
                I Depend On: jboss.jca:service=LocalTxDS,name=OracleDS
                jboss.jca:service=LocalTxPool,name=OracleDS
                jboss.jca:service=CachedConnectionManager
                jboss.security:name=JaasSecurityManager
                jboss.jca:service=RARDeployer

                Depends On Me: ]"