3 Replies Latest reply on Sep 30, 2002 11:37 PM by Derek Knuese

    Datasource Not Starting

    Derek Knuese Newbie

      I am trying to set up an SAP DB datasource. I have followed the instructions as specified here:

      http://www.jboss.org/modules/bb/index.html?module=bb&op=viewtopic&t=forums/ I start JBoss and browse to the console I see my service there, but it has a State of 0/Stopped. If I start the service through the console everything is fine from then on. (Without doing this the service is not bound in jndi.)

      What did I miss? How can I get my service to start automatically when JBoss starts up?

      Thanks!

        • 1. Re: Datasource Not Starting
          David Jencks Master

          If you look carefully at the server.log you will probably find the problem. Look for the mbeans in the sapdb-service.xml file. If it is not obvious what is wrong post the relevant section of the log.

          Did you put the driver in server/[conf]/lib?

          • 2. Re: Datasource Not Starting
            Derek Knuese Newbie

            The driver jar is in the correct lib dir and I do not see any messages/exceptions in the log.

            Again, if I go to the console, I see my connection pool there, but it has a state of 'Stopped'. I can start it by invoking the MBean start() operation and then
            everything is fine -- my app can access the database.

            Attached is the log contents where it looks like my service is being created (sapdb.log).


            Here is a copy of my sapdb-service.xml:



            <depends optional-attribute-name="ManagedConnectionFactoryName">
            <!--embedded mbean-->

            SapdbDS


            <config-property name="ConnectionURL" type="java.lang.String">jdbc:sapdb://127.0.0.1/TEST</config-property>
            <config-property name="DriverClass" type="java.lang.String">com.sap.dbtech.jdbc.DriverSapDB</config-property>
            <!--set these only if you want only default logins, not through JAAS -->
            <config-property name="UserName" type="java.lang.String">admin</config-property>
            <config-property name="Password" type="java.lang.String">admin</config-property>


            <depends optional-attribute-name="OldRarDeployment">jboss.jca:service=RARDeployment,name=JBoss LocalTransaction JDBC Wrapper



            <depends optional-attribute-name="ManagedConnectionPool">
            <!--embedded mbean-->

            3
            50
            5000
            15
            ByContainer


            <depends optional-attribute-name="CachedConnectionManager">jboss.jca:service=CachedConnectionManager
            <depends optional-attribute-name="JaasSecurityManagerService">jboss.security:service=JaasSecurityManager

            java:/TransactionManager
            jboss.jca:service=RARDeployer



            • 3. Re: Datasource Not Starting
              Derek Knuese Newbie

              Trying again to attach file...