2 Replies Latest reply on Nov 14, 2002 6:34 PM by Pierre CARION

    upgrading from 3.0.0 to 3.0.4 - problem with Postgres DS

    Marc Sturm Newbie

      Hello everyone!

      I have been very happy with JBoss3.0.0_tomcat4.0.3 working with Postgres. The application works very well. But I had this silly idea to reinstall everything on jboss3.0.4, so I re-did the same setup in order to access the postgres db; updating the xml files in 3.0.4 as in my setup in 3.0.0 but now it doesn't work, and I get an:

      2002-11-07 15:20:51,988 ERROR [org.jboss.deployment.scanner.URLDeploymentScanner] MBeanException: Exception in MBean operation 'checkIncompleteDeployments()'
      Cause: Incomplete Deployment listing:
      Packages waiting for a deployer:

      Incompletely deployed packages:

      MBeans waiting for classes:

      MBeans waiting for other MBeans:
      [ObjectName: jboss.jca:service=LocalTxCM,name=PostgresDS
      state: CONFIGURED
      I Depend On: jboss.jca:service=LocalTxDS,name=PostgresDS
      jboss.jca:service=LocalTxPool,name=PostgresDS
      jboss.jca:service=CachedConnectionManager
      jboss.security:name=JaasSecurityManager
      jboss.jca:service=RARDeployer

      Of course, as I said, the beans doesn't find any datasource - it doesn't work. I have been looking arround but haven't find any solution. Does anyone have an idea? Thanks a lot.

      Marc