1 Reply Latest reply on Dec 16, 2002 1:38 PM by Manoj Nair

    JBoss 3.2Beta2 and ORacle8.1.7 XA DS only works under JDK 1.

    Magnus Larsson Newbie

      I just noticed that a XA Datasource for Oracle8.1.7 under JBoss3.2beta2 does not work under JDK 1.3.1. It however works fine under JDK 1.4.

      Under JDK 1.3.1 I get an errormessage during startup when my CMP 2.0 entiy beans are activated:

      java.lang.LinkageError: loader constraints violated when linking javax/sql/ConnectionEventListener class

      Is JBoss 3.2 supposed to work under JDK 1.3.1?

      Regards,
      Magnus.