1 Reply Latest reply on Mar 7, 2003 11:07 PM by David Jencks

    JBoss 3.2RC3 Non Transaction Connection

    Jason Hill Newbie

      I'm trying to setup a local non-transaction datasource in 3.2RC3 using Oracle 9i, it seems to deploy okay. But when I try to access the pool I get a not bound jndi error. A Local TX pool works fine.


      <local-datasource>
      <jndi-name>ubsNonTxPool</jndi-name>
      <connection-url>URL=jdbc:oracle:thin:@myup:db</connection-url>
      <driver-class>oracle.jdbc.driver.OracleDriver</driver-class>
      <user-name>user</user-name>
      password
      </local-datasource>


      I also tried setting it up the old way using a service but it wouldn't deploy when I tried to use

      <depends optional-attribute-name="OldRarDeployment">jboss.jca:service=RARDeployment,name=JBoss NoTransaction JDBC Wrapper

      It would only deploy when I specified

      <depends optional-attribute-name="OldRarDeployment">jboss.jca:service=RARDeployment,name=JBoss LocalTransaction JDBC Wrapper

      Instead.

        • 1. Re: JBoss 3.2RC3 Non Transaction Connection
          David Jencks Master

          I think there's a notx-datasource tag to use for the *-ds.xml config (I might not remember the exact name)

          There is no NoTx jdbc wrapper. You could actually use either the local or xa wrapper, but I dont really see why you'd want to waste xa connections on a no tx ds:-) So the Local wrapper is the one to use.

          What makes it no-tx is the connectionmanager class used.