2 Replies Latest reply on Mar 21, 2003 1:29 PM by David Jencks

    Jboss3.0.6-Oracle

    cibo_1 Newbie

      HI, I have a problem setting up oracle pool for Jboss.
      I have gone through plenty of previous postings, but none fix my problem.
      The following is the thing that i have done:

      1. Copy the "classes12.jar" from "oracle/ora90/jdbc/lib" to the "jboss/server/default/lib" catalog. (the Oracle JDBC driver)

      2. Copy the "nls_charset12.jar" from "oracle/ora90/jdbc/lib" to the "jboss/server/default/lib" catalog. (Oralce language package)

      3. Copy the "ocrs12.jar" from "oracle/ora90/jdbc/lib" to the "jboss/server/default/lib" catalog. (don't remember)

      4. Copy the "jboss/docs/examples/jca/oracle-service.xml" file into the "jboss/server/default/deploy" catalog.

      5. Edit the file "jboss/server/default/deploy/oracle-service.xml":
      In the "OracleRealm" block
      <blabla..."UserName">yourOralceLogin</module-option>
      <blabla..."password">yourOraclePass</module-option>

      In the "ManagedConnectionFactoryProperties" block:
      <config-property name="ConnectionURL" type="java.lang.String">jdbc:oracle:thin@localhost:1521:yourDB</configure-property>

      localhost = your host (IP or DNS name) where you are running Oracle. An URL (eg "//oracle.foo.com" or "//129.129.129.129". Try both with and without "//")
      1521 = port no.
      yourDB = Oralce database name.

      <blabla...UserName"...>yourOracleLogin</config-property>
      <blabla...password"...>yourOraclePass</config-property>


      6. Edit the the first lines in the file "jboss/server/default/conf/standardjaws.xml":


      java:/OracleDS
      <type-mapping>Oracle8</type-mapping>
      false

      In /JBoss/server/default/conf/standardjbosscmp-jdbc.xml.
      Set

      java:/OracleDS
      <datasource-mapping>Oracle8</datasource-mapping>


      However, it seems that something is missing ot the jar file is not deployed properly.
      Is anyone there have the same problem?


      The following is the messages i've got when starting Jboss:


      11:44:57,667 ERROR [URLDeploymentScanner] MBeanException: Exception in MBean operation 'checkIncompleteDeployments()'
      Cause: Incomplete Deployment listing:
      Packages waiting for a deployer:

      Incompletely deployed packages:

      MBeans waiting for classes:

      MBeans waiting for other MBeans:
      [ObjectName: jboss.jca:service=LocalTxCM,name=OracleDS
      state: CONFIGURED
      I Depend On: jboss.jca:service=LocalTxDS,name=OracleDS
      jboss.jca:service=LocalTxPool,name=OracleDS
      jboss.jca:service=CachedConnectionManager
      jboss.security:name=JaasSecurityManager
      jboss.jca:service=RARDeployer

      Depends On Me: ]

      If there's anyone out there who had the same problem and get it fixed, could you please.... please... reply to me asap.
      Any help would be deeply appreciated.
      Thanks in advance.

        • 1. Re: Jboss3.0.6-Oracle
          John Crabtree Newbie

          I was able to get it to work by roughly following your steps. However, I am using oracle 8 and I noticed you are useing 9.

          All I had to do was:
          1. copy classes12.zip to default/lib
          2. copied oracle-service.xml from docs dir to default/deploy -- the only diffs are:
          a. changed JndiName to DefaultDS
          b. changed ConnectionURL to jdbc:oracle:thin:@localhost:1521:mydb
          c. added value to config-property name="UserName" of scott
          d. added value config-property name="Password" of tiger
          (NOTE: I missed c. and d. first time around since there is no obvious string to be replaced -- it is just blank)
          3. I changed one line in each of the default/conf files:
          standardjbosscmp-jdbc.xml and standardjaws.xml
          to <datasource-mapping>Oracle8</datasource-mapping>
          and <type-mapping>Oracle8</type-mapping>
          respectively.
          4. I also moved hsqldb-service.xml to a temp dir just to be sure.

          • 2. Re: Jboss3.0.6-Oracle
            David Jencks Master

            Start with the example config that comes with the version of jboss you are using. Your config file does not contain this line

            <depends optional-attribute-name="JaasSecurityManagerService">jboss.security:service=JaasSecurityManager


            (name != service)