4 Replies Latest reply on Mar 24, 2003 4:50 PM by Pervaz Allaudin

    Firebird BlobBuffer Length error

    Pervaz Allaudin Newbie

      I am having the darnest time converting Jboss from Hsql to firbird.

      I looked up earlier posts and put the Firbirdsql.jar in the ~/server/default/lib and the rar in the deploy dir.

      Modified the Firbird-service.xml for the local file system.

      I have taken out all Hsql referances and files; and also my test bean.

      While booting Jboss gives me an error which does seem to have happened to anybody else.
      in the serverlog I have - ERROR [org.jboss.resource.connectionmanager.XATxConnectionManager] Starting failed.
      java.lang.IllegalArgumentException: The class 'class org.firebirdsql.jca.FBManagedConnectionFactory' has no setter for config property 'BlobBufferLength'.

      Now FireBird Maps java.lang.object to Varchar(2000) - so I do not see where it is getting the need for the Blob and if I am to add it then what should be mapped to it and in which XML.

      I have also changed the jbossStandard_cmp.xml for Firbird.

        • 1. Re: Firebird BlobBuffer Length error
          David Jencks Master

          Only deploy the .rar into deploy. Do not deploy the firebirdsql.jar anywhere.

          You may have different versions of the driver in the .rar and .jar.

          On jboss 4 the ra.xml for this adapter doesn't quite work: the empty config-property-value elements need to be removed (at least for the BlobBufferLength). I will update the firebird cvs soon.

          If this doesn't help please supply the exact versions of jboss and the firebird adapter you are using.

          • 2. Re: Firebird BlobBuffer Length error
            Pervaz Allaudin Newbie

            Did you mean deploy the jar only in and do not deploy the rar anywhere.

            I ask because with rar only I got errors to the order:

            [org.jboss.system.ServiceConfigurator] Failed to complete install
            java.lang.ClassNotFoundException: No ClassLoaders found for: org.firebirdsql.management.FBManager
            at org.jboss.mx.loading.LoadMgr.beginLoadTask(LoadMgr.java:155)
            and
            jboss.jca:service=FirebirdManager is not registered.
            a few times.

            While with jar only it seems to more or less get to the end without any large errors and I see Firebird in the console.

            I do still get:

            2003-03-23 20:55:26,671 ERROR [org.jboss.deployment.scanner.URLDeploymentScanner] MBeanException: Exception in MBean operation 'checkIncompleteDeployments()'
            Cause: Incomplete Deployment listing:
            Packages waiting for a deployer:

            Incompletely deployed packages:

            MBeans waiting for classes:

            MBeans waiting for other MBeans:
            [ObjectName: jboss.jca:service=XaTxCM,name=FirebirdDS
            state: CONFIGURED
            I Depend On: jboss.jca:service=XaTxDS,name=FirebirdDS
            jboss.jca:service=XaTxPool,name=FirebirdDS
            jboss.jca:service=CachedConnectionManager
            jboss.security:service=JaasSecurityManager
            jboss.jca:service=RARDeployer

            Depends On Me: , ObjectName: jboss.jca:service=XaTxDS,name=FirebirdDS
            state: CONFIGURED
            I Depend On: jboss.jca:service=RARDeployment,name=Firebird Database Connector

            Depends On Me: jboss.jca:service=XaTxCM,name=FirebirdDS
            ]

            I also still get not bound error when I try to test my bean and I am not sure whther it is this or some other error on my part. As far as I can tell it creates the database but the bean gives FirebirdDS not bound.

            Thanks, I appreciate your help

            Pervaz

            • 3. Re: Firebird BlobBuffer Length error
              Robert Costin Newbie



              Hi

              I’ve got the same problem using :
              jboss-3.0.6_tomcat-4.1.18
              and
              FirebirdSQL-1.0.0RC3.

              Here’s how I’ve “fix” it :

              1. I put the firebirdsql.rar and firebird-service.xml into the deploy directory.

              2. I commented out the first mbean (name="jboss.jca:service=FirebirdManager" ) in the firebird-service.xml .

              3. I commented out the config-property with name="BlobBufferLength" in the mbean with name="jboss.jca:service=XaTxDS,name=FirebirdDS"

              I hope this helps

              • 4. Re: Firebird BlobBuffer Length error
                Pervaz Allaudin Newbie

                Thanks everybody and especially RobertCostin, alls well and I tested a bean ok.

                I did one variation though. I did not remove the first bean and only commented out the BlobBufferLength property. That worked out just fine.

                Thanx again
                PervazA