1 Reply Latest reply on May 21, 2003 7:31 PM by David Jencks

    Trouble Deploying Custom Resource Adapter

    exitsfunnel Newbie

      Hello,

      I'm trying to deploy a custom Resource Adapter, I've writen and I'm having some trouble. Actually, I don't think there are any errors when I start the server but when I try and access a connection factory from a servlet I get an error telling me that nothing is bound to the specified JNDI name. I should mention that I had sometime ago successfully deployed in JBoss 3.0.6 so I don't think that there is a funcamental problem with my code.

      I'm confused enough by how stuff fits together now that I'll just start with a general question: Is the information in the JCA chapter in the 3.0 quick start guide still relevent? I'm trying to reconcile it with, for instance, the example firebird adapter and it doesn't seem to agree. For instance, there is no reference to FirebirdDBRealm anywhere in firbird-ds.xml.

      I"ve attached my configuration files; it anyone could point me in the right direction, I'd really appreciate it. Thanks in advance.

      -exits

        • 1. Re: Trouble Deploying Custom Resource Adapter
          David Jencks Master

          Your *-ds.xml file looks ok to me. Since you aren't using a login module you don't need to modify login-config.xml.

          The quick start guide is pretty irrelevant now.

          Scott recently posted some newer directions for 3.2.1, I think on the sourceforge downloads page.

          Are the mbeans for the resource adapter and the connection factory deployment visible in jmx-console and are they started? What does the log say?