1 Reply Latest reply on Jun 20, 2003 4:28 PM by mpatnode

    Was working with JBOSS-3.0.2 & doesn't works with JBOSS-3.2.

    Ram Newbie

      We are using NoTxConnectionManager Mbean to connect to DB2DS database. (Configuration is attached below).

      This Mbean used to work great in JBOSS-3.0.2, where as with JBOSS-3.2.1 it blows out with following exception:

      12:41:50,604 INFO [ServiceConfigurator] Problem configuring service jboss.jca:service=NoTxDS,name=DB2DS
      org.jboss.deployment.DeploymentException: No Attribute found with name: JndiName
      at org.jboss.system.ServiceConfigurator.configure(ServiceConfigurator.java:332)


      ===================================
      Here goes Mbean Configuration:

      <?xml version="1.0" encoding="UTF-8"?>


      <depends optional-attribute-name="ManagedConnectionFactoryName">
      <!--embedded mbean-->

      VFDataSource


      <config-property name="ConnectionURL" type="java.lang.String">jdbc:db2:VICDB02</config-property>
      <config-property name="DriverClass" type="java.lang.String">COM.ibm.db2.jdbc.app.DB2Driver</config-property>
      <!--set these only if you want only default logins, not through JAAS -->
      <config-property name="UserName" type="java.lang.String">xyz123</config-property>
      <config-property name="Password" type="java.lang.String">xyz123</config-property>


      <!--Below here are advanced properties -->
      <!--hack-->
      <depends optional-attribute-name="OldRarDeployment">jboss.jca:service=RARDeployment,name=JBoss LocalTransaction JDBC Wrapper


      <depends optional-attribute-name="ManagedConnectionPool">
      <!--embedded mbean-->

      0
      100
      5000
      15
      ByContainer


      <depends optional-attribute-name="CachedConnectionManager">jboss.jca:service=CachedConnectionManager
      <depends optional-attribute-name="JaasSecurityManagerService">jboss.security:service=JaasSecurityManager
      jboss.jca:service=RARDeployer



      ===============================

      Have any of you guys come across this problem? Is this is a bug in JBOSS-3.2.1? - because I have configured attribute with name JndiName