1 Reply Latest reply on Nov 17, 2003 6:45 PM by b_boyle18

    Problem with JBoss-CMP.xml

    b_boyle18 Newbie

      Hi!
      I'm using lomboz to setup an example of CMP. I'm using oracle 8i as my datasource so I've modified oracle-service.xml to reflect that. When I run JBoss I get the error "Error in jbosscmp-jdbc.xml : datasource-mapping PLEASE_MODIFY_THIS not found" My jbosscmp.xml is as follows....

      PLEASE_MODIFY_THIS
      <datasource-mapping>PLEASE_MODIFY_THIS</datasource-mapping>
      <preferred-relation-mapping>PLEASE_MODIFY_THIS</preferred-relation-mapping>


      What do I put in place of PLEASE_MODIFY_THIS? WHy do I have to do this if I've already specified my datasource in oracle-service.xml?? Or are these completely different things. If someone could explain this to me it would great.
      Thanks.
      P.S. My database is BBoyle@Boyle
      and my oracle-service is...

      <config-property name="ConnectionURL" type="java.lang.String">jdbc:oracle:thin:@youroraclehost:1521:yoursid</config-property>
      <config-property name="ConnectionURL" type="java.lang.String">jdbc:oracle:oci:@BOYLE</config-property>
      <!--set these only if you want only default logins, not through JAAS -->
      <config-property name="UserName" type="java.lang.String">BBOYLE</config-property>
      <config-property name="Password" type="java.lang.String">password</config-property>

        • 1. Re: Problem with JBosscmp-jdbc.xml
          b_boyle18 Newbie

          Hi!
          I've made a mistake in the title. It is jbosscmp-jdbc.xml that I am having problems with.
          I've got as far as to add in my datasource. I've looked at a few examples and for datasource mapping I've seen things like mySQLDS for a mySQL database. I tried putting in OracleDS but that didnt work, so at the moment it looks like this.

          Java:/OracleDS
          <datasource-mapping>OracleDS</datasource-mapping>
          <preferred-relation-mapping>foreign-key</preferred-relation-mapping>