1 Reply Latest reply on Jan 29, 2004 2:11 PM by Jeff Gettle

    Connection Leak in JBoss 3.2.3

    Roger Tan Newbie

       

      "divine_comedy" wrote:
      we just migrated from JBoss 3.0.4 to JBoss 3.2.3. There seems to be some connection leak inside JBoss ( we did not change any code ) over time, but it could be that I've configured things wrongly so here's a sample config ( I got this to work ), the problem only occurs when many of the developers are connecting at the same time. We have about 5 machines running ( non of which is doing anything strenuous ) when we see that the total connection to the database ( from all machines ) exceeds the maximum allowable ( set by the database ). Anything missing ?

      <local-tx-datasource>

      <!-- The jndi name of the DataSource, it is prefixed with java:/ -->
      <!-- Datasources are not available outside the virtual machine -->
      <jndi-name>SomeDS</jndi-name>

      <connection-url>@SOMESCHEMA@</connection-url>

      <!-- The driver class -->
      <driver-class>oracle.jdbc.driver.OracleDriver</driver-class>

      <!-- The login and password -->
      <user-name>@SOMEUSER@</user-name>
      <password>@SOMEPASSWORD@</password>
      <!-- The minimum connections in a pool/sub-pool. Pools are lazily constructed on first use -->
      <min-pool-size>5</min-pool-size>

      <!-- The maximum connections in a pool/sub-pool -->
      <max-pool-size>50</max-pool-size>

      <!-- The time before an unused connection is destroyed -->
      <!-- NOTE: This is the check period. It will be destroyed somewhere between 1x and 2x this timeout after last use -->
      <!-- TEMPORARY FIX! - Disable idle connection removal, HSQLDB has a problem with not reaping threads on closed connections -->
      <idle-timeout-minutes>0</idle-timeout-minutes>
      <!-- Whether to check all statements are closed when the connection is returned to the pool,
      this is a debugging feature that should be turned off in production -->
      <track-statements>true</track-statements>
      </local-tx-datasource>