6 Replies Latest reply on Jan 8, 2004 10:41 AM by Dominique Jean-Prost

    MSSqlServer datasource configuration

    Dominique Jean-Prost Newbie

      Hello,


      I'm quite new to JBoss though I know well Weblogic.

      I'm trying to setup a DataSource with SQLServer. When starting, I get the following log entry
      14:34:06,831 INFO [MainDeployer] Starting deployment of package: file:/C:/bin/jboss/server/default/deploy/sofaxis-ds.xml
      14:34:07,182 INFO [RARDeployment] Started jboss.jca:service=ManagedConnectionFactory,name=sofaxis
      14:34:07,182 INFO [JBossManagedConnectionPool] Started jboss.jca:service=ManagedConnectionPool,name=sofaxis
      14:34:07,192 INFO [MainDeployer] Deployed package: file:/C:/bin/jboss/server/default/deploy/sofaxis-ds.xml

      but, I see no connection to my database.

      Here is my datasource configuration:

      <local-tx-datasource>
      <jndi-name>sofaxis</jndi-name>
      <connection-url>jdbc:inetdae7:orlwendolene?database=dexiasofaxis</connection-url>
      <driver-class>com.inet.tds.TdsDriver</driver-class>
      <user-name>sa</user-name>

      <check-valid-connection-sql>select 1 from systypes</check-valid-connection-sql>
      <new-connection-sql>select * from systypes</new-connection-sql>
      <connection-property name="prepare">false</connection-property>
      <connection-property name="appname">djp_jboss</connection-property>
      <min-pool-size>1</min-pool-size>
      <max-pool-size>5</max-pool-size>
      </local-tx-datasource>



      I tried to change user-name to foo and it doesn't anything more.

      Where am I wrong.

      Regards,
      Dom