2 Replies Latest reply on Feb 14, 2003 12:29 AM by alvin

    Template Example - EjbDocletTask ClassNotFound

    Srinivas Jamched Newbie

      I am trying to get the template example deployed in jboss in win2k, I ran into an issue, below is what I have so far

      ant: 1.5.1
      xdoclet: 1.2b2
      jboss: 3.0.4


      init:
      [echo] build.compiler = ${build.compiler}
      [echo] user.home = C:\Documents and Settings\Administrator
      [echo] java.home = E:\j2sdk1.4.0_03\jre
      [echo] ant.home = E:/jakarta-ant-1.5.1
      [echo] jboss.home = E:/jboss-3.0.4_tomcat-4.1.12
      [echo] xdoclet.home = E:/xdoclet-bin-1.2b2
      [echo] java.class.path = E:\j2sdk1.4.0_03\lib\tools.jar;E:/jakarta-ant-1.5.1\lib\xml-apis.jar;E:/jakarta-ant-1.5.1\lib\xer
      cesImpl.jar;E:/jakarta-ant-1.5.1\lib\optional.jar;E:/jakarta-ant-1.5.1\lib\ant.jar;


      xdoclet-generate:

      BUILD FAILED
      file:E:/jboss-3.0.4_tomcat-4.1.12/docs/examples/template/build.xml:140: taskdef class xdoclet.ejb.EjbDocletTask cannot be found



      I believe I added the xdoclet-ejb-module-1.2b2.jar to the path


















      I tried soemthing like this in the build.xml as well















      When I run ant -debug I see for both the cases above,


      Property ${base.path} has not been set
      [echo] base.path = ${base.path}
      Property ${xdoclet.path} has not been set
      [echo] xdoclet.path = ${xdoclet.path}


      I am able to run the xdoclet "ant ejbdoclet" sucessfully.

      What am I missing? How can I fix this?

      Thanks for your help.

      Srini