0 Replies Latest reply on Apr 4, 2005 10:05 AM by Nick de Graeve

    Examples won't compile on some machines

    Nick de Graeve Newbie

      We have 4 pc's on which we tried to compile the JBoss 4 Guide examples. On 2 machines it succeeded, on 2 it failed with message:

      [javac] C:\JBoss\jboss4guide\examples\src\main\org\jboss\chap8\ex2\JndiUserAndPass.java:33:
      abstract method initialize(javax.security.auth.Subject
      ,javax.security.auth.callback.CallbackHandler
      ,java.util.Map<java.lang.String,?>
      ,java.util.Map<java.lang.String,?>)
      in javax.security.auth.spi.LoginModule cannot be accessed directly
      [javac] super.initialize(subject, callbackHandler, sharedState, options);
      [javac] ^
      [javac] C:\JBoss\jboss4guide\examples\src\main\org\jboss\chap8\ex2\JndiUserAndPass.java:33: warning: [unchecked] unchecked conversion
      [javac] found : java.util.Map
      [javac] required: java.util.Map<java.lang.String,?>
      [javac] super.initialize(subject, callbackHandler, sharedState, options);

      java version: result
      --------------------
      1.5.0-beta2: success
      1.5.0_01: success
      1.5.0_02: failure (2 different machines)

      The 2 pc's that fail had an older (don't know which) version of JDK 1.5 but because it didn't compile, they were updated to the latest version. It still doesn't work, though.
      All of us have the latest source.

      What could be wrong?