2 Replies Latest reply on Aug 28, 2003 9:55 AM by oscpro

    a pseudo attribute name is expected

    oscpro Newbie

      Hi,

      I tried to use AOP inside JBoss so I made a jar file called: aop-intercept.aop with the following content:

      
      File
      -----------------------------------------------
      meta-inf/
      meta-inf/manifest.mf
      meta-inf/
      META-INF/jboss-aop.xml
      org/
      org/xenata/
      org/xenata/interceptor/
      org/xenata/interceptor/TracingInterceptor.class
      -----------------------------------------------
      8 files
      
      


      the jboss-aop.xml file has the following content:

      <?xml version="1.0" encoding="UTF-8">
      <aop>
       <interceptor-pointcut class="org.xenata.pojo.Pojo">
       <interceptors>
       <interceptor class="org.xenata.interceptor.TracingInterceptor" />
       </interceptors>
       </interceptor-pointcut>
      </aop>
      


      When dropping the aop-intercept.aop file into the deployement folder I get the following exception:

      11:35:22,765 ERROR [AspectDeployer] failed to parse AOP document:
      org.dom4j.DocumentException: Error on line 1 of document jar:file:/mnt/desktop/misc/laptop/home/jboss/projects/others/aop/jboss-4.0.0DR2/server/default/tmp/deploy/server/default/deploy/aop-intercept.aop/2.aop-intercept.aop!/META-INF/jboss-aop.xml : a pseudo attribute name is expected. Nested exception: a pseudo attribute name is expected.
       at org.dom4j.io.SAXReader.read(SAXReader.java:339)
       at org.dom4j.io.SAXReader.read(SAXReader.java:218)
       at org.jboss.aop.deployment.AspectDeployer.parseDocument(AspectDeployer.java:131)
       at org.jboss.aop.deployment.AspectDeployer.init(AspectDeployer.java:104)
       at org.jboss.deployment.MainDeployer.init(MainDeployer.java:650)
       at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:582)
       at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:558)
       at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      ...
      


      What is wrong with my archive?

      Thanks