4 Replies Latest reply on Nov 27, 2004 6:07 AM by Kabir Khan

    Problems with installing AOPFinal to JBoss4.0

    nono onon Newbie

      Hi,
      I wanted to try out ejb3.0 with JBoss, which is why I tried to installed the AOP-stuff to my Jboss4.0.....but unfortunalely I was not successful...what is my mistake?? Can anybody help me??..Here is what I did...

      1.) downloaded JBOSS + unzipped C:\jboss-4.0.0RC1
      2.) downloaded JAVA1.5 + set the JAVA_HOME environment variable
      3.) downloaded jboss-aop_1.0.0-FINAL.zip + unzipped it into a directory far away from JBOSS_HOME
      4.) copied the directory jboss-aop-jdk50.deployer from the
      /jboss-40-install of the jboss-aop_1.0.0-FINAL to
      jboss-4.0.1/server/all/deploy
      5.) Run the all- confiruration of JBOSS with run -c all

      6.) Receive the following messages during startup:
      22:46:22,912 ERROR [URLDeploymentScanner] Incomplete Deployment listing:
      Packages waiting for a deployer:
      org.jboss.deployment.DeploymentInfo@c67c433d { url=file:/C:/jboss-4.0.0RC1/serv
      r/all/deploy/jboss-aop-jdk50.deployer/ }
      deployer: null
      status: null
      state: INIT_WAITING_DEPLOYER
      watch: file:/C:/jboss-4.0.0RC1/server/all/deploy/jboss-aop-jdk50.deployer/
      altDD: null
      lastDeployed: 1101332782912
      lastModified: 1101330769116
      mbeans:

      *************************************************************
      The effect is that I also cannot run the ejb3.0 examples from the tutorial, because ant tells me this:
      Buildfile: Build.xml

      C:\jboss-4.0.0RC1\server\all\deploy\jboss-aop.deployer not found

      *************************************************
      DOES ANYBODY HAVE AN IDEA...WHERE IS MY MISTAKE??? I THOUGHT I DID EVERYTHING AS DESCRIBED IN THE TUTORIALS???