5 Replies Latest reply on Jul 19, 2007 7:47 AM by Kabir Khan

    ProfileService aspects are no longer being applied

    Scott Stark Master

      As I'm looking at the ProfileServiceUnitTestCase failures in more detail I see that none of the aspects registered in the bootstrap-repo-beans.xml AspectManager config are being applied to the deployers.

       <bean name="AspectManager" class="org.jboss.aop.deployers.AspectManagerJDK5">
       <constructor>
       <parameter><![CDATA[
       <aop>
       <aspect name="deployers" class="org.jboss.profileservice.aop.DeployerAspects"/>
       <bind pointcut="execution(* $instanceof{org.jboss.deployers.spi.deployer.Deployer}->prepareDeploy(..))">
       <advice name="invoke" aspect="deployers"/>
       </bind>
       <bind pointcut="execution(* $instanceof{org.jboss.deployers.spi.deployer.Deployer}->prepareUndeploy(..))">
       <advice name="invoke" aspect="deployers"/>
       </bind>
       <bind pointcut="execution(* $instanceof{org.jboss.deployers.spi.deployer.Deployer}->commitDeploy(..))">
       <advice name="invoke" aspect="deployers"/>
       </bind>
       <bind pointcut="execution(* $instanceof{org.jboss.deployers.spi.deployer.Deployer}->commitUndeploy(..))">
       <advice name="invoke" aspect="deployers"/>
       </bind>
      
       <aspect name="attachments" class="org.jboss.profileservice.aop.TrackingAdvice"/>
       <bind pointcut="execution(* $instanceof{org.jboss.deployers.spi.attachments.Attachments}->addAttachment(..))">
       <advice name="addAttachment" aspect="attachments"/>
       </bind>
       </aop>]]>
       </parameter>
       </constructor>
       <property name="enableLoadtimeWeaving">false</property>
       <!-- only relevant when EnableLoadtimeWeaving is true.
       When transformer is on, every loaded class gets
       transformed. If AOP can't find the class, then it
       throws an exception. Sometimes, classes may not have
       all the classes they reference. So, the Suppressing
       is needed. (i.e. Jboss cache in the default configuration -->
       <property name="suppressTransformationErrors">true</property>
       <property name="prune">true</property>
       <property name="include">org.jboss.test., org.jboss.injbossaop., org.jboss.deployers.</property>
       <property name="exclude">org.jboss.</property>
       <!-- This avoids instrumentation of hibernate cglib enhanced proxies
       <property name="ignore">*$$EnhancerByCGLIB$$*</property> -->
       <property name="optimized">true</property>
       <property name="verbose">false</property>
       <!--
       Available choices for this attribute are:
       org.jboss.aop.instrument.ClassicInstrumentor (default)
       org.jboss.aop.instrument.GeneratedAdvisorInstrumentor
       <property name="instrumentor">org.jboss.aop.instrument.ClassicInstrumentor</property>
       -->
       </bean>
      

      Can you look into why this is now failing?