2 Replies Latest reply on Sep 19, 2005 11:20 AM by Alexey Loubyansky

    Jboss 4.0.2 testsuite - HAConnectionFactoryUnitTestCase erro

    partha sarathi Newbie

      Hello All,

      While running the testcase org.jboss.test.jca.test.HAConnectionFactoryUnitTestCase in jboss-4.0.2 using HP-UX machines gives the following error.

      Could not create connection using any of the URLs: [jdbc:hsqldb:hsql://localhost:1702, jdbc:hsqldb:hsql://localhost:1703, jdbc:hsql:hsql://localhost:1234]

      Can any one suggest how to solve this problem?

      Thanks,
      Partha

        • 1. Re: Jboss 4.0.2 testsuite - HAConnectionFactoryUnitTestCase
          Kathiravan Velusamy Newbie

          Hello Parthasarathi,

          I too have this problem on linux.
          When I debugged the "org.jboss.test.jca.test.HAConnectionFactoryUnitTestCase" test case,
          I have found that the JBoss server connection was closed when tries to stop and start the HSQLDB server in the test case.

          The snippet of this scenario available in the test code is given below,

          HAConnectionSessionBean.java :

          *******************snip*************************

          ObjectName db = new ObjectName("jboss:service=Hypersonic,database=haLocalDB1");
          MBeanServer server = MBeanServerLocator.locateJBoss();
          server.invoke(db, "start", null, null);
          //... some database access ...
          server.invoke(db, "stop", null, null);


          // again start
          server.invoke(db, "start", null, null);
          //... some database access ...
          server.invoke(db, "stop", null, null);

          *******************snip*************************

          test-ha-ds.xml:

          *******************snip*************************


          1701
          true
          testHaLocalDB1
          false
          true


          *******************snip*************************


          If I Connect hsqldb server ,first time it connected to the server. Once the that hasqldb server stopped it couldnot start the connection again to the database.

          I couldn't locate the problem.

          Regards,
          Kathir