It seems like this could be a standalone task:
Is there a problem with our existing naming convention? I prefer to keep it instead of coming up with yet another property for these values. The node * properties are well known and documented, I'd hate to do all that again.
I definitely prefer java.net.NetworkInterfafce over hard coding anything using env variables.
So we need to keep the ability for folks to override these properties. We also need to make sure that there are no duplicates if they do. Although the task could complain if an existing node* property contains an invalid IP address.