2 Replies Latest reply on Feb 6, 2004 4:18 AM by Giovanni Formenti

    JBossNET: method with argument

    Giovanni Formenti Newbie

      Hallo!

      I write a session bean exposed as a web service with JBoss.NET and XDoclet...
      If i try to call a test() method (it return a String) all is right!
      But if I try to call a method with a String parameter like test2(String test) it doesn't work! :(

      The error is:

      java.lang.NoClassDefFoundError
      at org.apache.axis.message.RPCHandler.onStartChild(RPCHandler.java:326)
      at org.apache.axis.encoding.DeserializationContextImpl.startElement(DeserializationContextImpl.java:963)
      at org.apache.axis.message.SAX2EventRecorder.replay(SAX2EventRecorder.java:198)
      at org.apache.axis.message.MessageElement.publishToHandler(MessageElement.java:722)
      at org.apache.axis.message.RPCElement.deserialize(RPCElement.java:233)

      Any idea?!

      Gio

        • 1. Re: JBossNET: method with argument
          Dr. Christoph Georg Jung Newbie

          Strange, this should work (and works in our testsuite and in productive environments). So which jboss release do you use?

          Unfortunately, the NoClassDefFound is not very verbose as it is usually a sign that there is some implicit dependency not fulfilled.

          Do you have any hint which class is required at this place? Could you please debug the server to the point where it appears and maybe get this information for me?

          • 2. Re: JBossNET: method with argument
            Giovanni Formenti Newbie

            Thanx for ur reply!

            I deployed the EAR in a "default.net" server (a "default" server with the jboss-net.sar) because i don't want to load all the services of "all" server.
            Today I try the deploy in the "all" directory and it seems to work... maybe i need to put some JAR to the "default.net/lib" directoy.
            Any idea about the missing JARs?

            Gio