6 Replies Latest reply on Apr 4, 2008 10:48 AM by Richard Opalka

    JBossWS 3.0.1 Release Issues

    Richard Opalka Master

      This thread will track all 3.0.1 release related issues including proposals how to fix them

        • 1. Re: JBossWS 3.0.1 Release Issues
          Richard Opalka Master

          Folks, I'm creating SPI 1.0.2 GA release artifact. According to:

          http://jbws.dyndns.org/mediawiki/index.php?title=Release_Procedure

          we can't have references to SNAPSHOT thirdparty dependencies in version properties.
          However our current SPI references

          jboss-javaee=5.0.0-SNAPSHOT

          At the moment I don't see more appropriate artifact to refer to:

          [/home/opalka][/opt/svn/jboss.local.repository/jboss/jboss-javaee]>svn list https://svn.jboss.org/repos/repository.jboss.org/jboss/jboss-javaee
          5.0.0-SNAPSHOT/
          5.0.0.Beta3/
          5.0.0.Beta3Update1/


          Should I use 5.0.0.Beta3 instead of 5.0.0-SNAPSHOT?

          • 2. Re: JBossWS 3.0.1 Release Issues
            Richard Opalka Master

            The following is copy/paste from our current SPI version properties. Are the following thirdparty dependencies still up2date?

            # Thirdparty library versions
            apache-ant=1.6.5
            dom4j=1.6.1
            gnu-getopt=1.0.10
            jboss-common-core=2.0.2.GA
            jboss-common-logging-log4j=2.0.2.GA
            jboss-common-logging-spi=2.0.2.GA
            jboss-javaee=5.0.0-SNAPSHOT
            jboss-jbossxb=1.0.0.GA-brew
            jboss-microcontainer=2.0.0.Beta3
            sun-jaf=1.1
            sun-jaxb=2.1.4
            sun-jaxrpc=1.1
            sun-jaxws=2.1.1
            sun-servlet=2.5
            junit=3.8.1


            I'm asking because we're doing QA against AS Beta 4 and I see the following MC artifacts at the moment:

            [/home/opalka][/opt/svn/jboss.local.repository/jboss/microcontainer]>svn list https://svn.jboss.org/repos/repository.jboss.org/jboss/microcontainer
            0.9.1/
            0.9.2/
            0.9.3/
            0.9.4/
            0.9.5/
            1.0.0/
            1.0.1/
            1.0.2/
            2.0.0.Beta/
            2.0.0.Beta10/
            2.0.0.Beta10.1/
            2.0.0.Beta11/
            2.0.0.Beta2/
            2.0.0.Beta3/
            2.0.0.Beta3.1/
            2.0.0.Beta4/
            2.0.0.Beta5/
            2.0.0.Beta6/
            2.0.0.Beta7/
            2.0.0.Beta8/
            2.0.0.Beta9/
            snapshot/
            snapshot-classloader/
            snapshot-metadata/
            snapshot-temp/
            


            I would say we should refer to 2.0.0.Beta4 in version properties don't we?

            • 3. Re: JBossWS 3.0.1 Release Issues
              Richard Opalka Master

              Folks, it is our responsibility to publish our release artifacts to the maven2 repository right?
              I guess we will publish only final and completely QA-ed artifacts there, right?

              • 4. Re: JBossWS 3.0.1 Release Issues
                Richard Opalka Master

                 

                "richard.opalka@jboss.com" wrote:

                Should I use 5.0.0.Beta3 instead of 5.0.0-SNAPSHOT?

                I'm using

                jboss-javaee=5.0.0.Beta3Update1

                at the moment.

                • 5. Re: JBossWS 3.0.1 Release Issues
                  Thomas Diesler Master

                  Yes, we should use the most up-to-date versions that the target containers use. For the SPI this is a compile time dependency only. So it does not matter so much.

                  Important is, that the information in component-info.xml is in sync with what the target container use.

                  • 6. Re: JBossWS 3.0.1 Release Issues
                    Richard Opalka Master

                     

                    "yhrn" wrote:
                    Hi,
                    I was told to re-open JBWS-1714 but I can't. I have posted a comment and attached an example though.

                    Cheers,
                    Mattias

                    I reopened it ;)