0 Replies Latest reply on Jun 21, 2006 3:46 PM by Longfang Q

    multiple service in tomcat server.xml

    Longfang Q Newbie

      I am using jboss 4.0.4.
      I added another service in tomcat jboss_dir\server\default\deploy\jbossweb-tomcat55.sar\server.xml. I can access the web pages from browser from the service I added.
      But jboss does not seem to look at the jboss-web.xml.
      It ignores the context root and security domain I setup in jboss-web.xml
      . If I put the same web app under the jboss.web service, everything is fine. What do I miss ?

      thanks a lot.

      <Service name="my.web"
       className="org.jboss.web.tomcat.tc5.StandardService">
      
       <Connector port="8081" address="${jboss.bind.address}"
       maxThreads="250" strategy="ms" maxHttpHeaderSize="8192"
       emptySessionPath="true"
       enableLookups="false" redirectPort="8643" acceptCount="100"
       connectionTimeout="20000" disableUploadTimeout="true"/>
      
      
       <Engine name="my.web" defaultHost="xxx">
      
       <Realm className="org.jboss.web.tomcat.security.JBossSecurityMgrRealm"
       certificatePrincipal="org.jboss.security.auth.certs.SubjectDNMapping"
       allRolesMode="authOnly"
       />
      
       <Host name="xxx"
       autoDeploy="true" deployOnStartup="true" deployXML="true" appBase="c:/webApps2">
       <Valve className="org.apache.catalina.valves.FastCommonAccessLogValve"
       prefix="xxx_2_access_log." suffix=".log"
       pattern="common" directory="${jboss.server.home.dir}/log"
       resolveHosts="false" />
       </Host>
       </Engine>
      
       </Service>